11/20 21:00 build switched my theme from modern to classic

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
16 years ago
13 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: David Hyatt)

Tracking

Trunk
mozilla1.1alpha

Firefox Tracking Flags

(Not tracked)

Details

I rebuilt this morning, and when I rand, my theme had switched from modern to 
classic.  (Bienvenu saw this, too.)

I haven't investigated, but maybe the fix for 
http://bugzilla.mozilla.org/show_bug.cgi?id=109488 caused this.

it would be bad if 0.9.6 -> 0.9.7 switched themes on everyone 
(or Netscape 6.2 -> Netscape Next Release)
confirming on all platforms.  A bunch of people (including me) in #mozillazine
saw this last night with the 9pm build so it wasn't bug 109488 which didn't get
checked in until around 3pm today.  Something happened the night before which
caused it.  Updating summary.
OS: Windows 2000 → All
Hardware: PC → All
Summary: 11/21 build switched my theme from modern to classic → 11/20 21:00 build switched my theme from modern to classic
Erm, correction.  I was looking at the bug resolved time, not checkin time. so
it is possible that it was caused by that bug which got checked in at 4pm on the
20th.  sorry for the confusion.

Comment 3

16 years ago
Switching back to Modern seems to keep the Modern setting, btw.

Comment 4

16 years ago
I my case, I switched back to modern, and restarted the browser. It came up in
the classic theme, but after I started browsing it magically switched itself to
Modern. It is possible it would have done that without actively trying to set it
back to the proper theme myself. Very odd, and transient. At least the
work-around seems to be 'ignore it, it goes away'

Comment 5

16 years ago
Could someone please tell me what file the user theme preference should be found?

When i go to the relevant profile subdirectory of my .mozilla directory (i'm in
Linux) and do:

   strings * | grep lassic

i get no result. A similar search for "dern" (to find "Modern") or for "theme"
also finds absolutely nothing. I would have thought that the theme preference
would be in a JavaScript file, such as prefs.js.
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1

Comment 6

16 years ago
But isn't this bug WORKSFORME? I have been able to switch recent builds (such as
Linux trunk 2001-11-27-21) back to Modern on two different machines.

And while someone is reading this, could you please tell me which the user theme
preference is stored in, as asked in the preceding comment? Thanks.

Comment 7

16 years ago
Since this seems to have been an isolated case, this bug should probably be
closed as WORKSFORME.
How have you guys tested this to claim it worksforme?  Here are some steps to
reproduce:

1.  Download and install an older copy of Mozilla, eg. 0.9.5 or 0.9.6.
2.  On first running, create a new profile and set the theme to Modern.
3.  Re-start a few times to make sure the pref sticks.
4.  Upgrade to a build on or after 11/20 21:00.
5.  Start the new build with the same profile you created.

Downloading the 11/20 21:00 build will revert it to Classic.  Possibly newer
builds will not.  If someone can confirm that upgrading to a recent build in
step 4 will not revert your theme to classic, then that is a valid claim of WFM.
*** Bug 113172 has been marked as a duplicate of this bug. ***
*** Bug 118244 has been marked as a duplicate of this bug. ***
nominating based on sspitzers original report.
Keywords: nsbeta1
*** Bug 116786 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
nsbeta1- per Nav triage team
Keywords: nsbeta1 → nsbeta1-

Comment 14

14 years ago
Is this still relevant?
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.