general.useragent.override set to browser version less than 5 returns error on executing Mozilla.

VERIFIED DUPLICATE of bug 83376

Status

defect
VERIFIED DUPLICATE of bug 83376
18 years ago
14 years ago

People

(Reporter: dan, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/6 [en] (compatible; MSIE 5.5; Windows NT 5.0)
BuildID:    20011112

 As above, it I set the value of general.useragent.override to "Mozilla/4.7 [en]
(compatible; MSIE 5.5; Windows NT 5.0)" Mozilla throws up an error on execution.
If the value is set to "Mozilla/5....." Mozilla boots. Why is this? 

Reproducible: Always
Steps to Reproduce:
1. Set value of general.useragent.override to "Mozilla/4.7 [en] ()", mozilla
throws up an error
2. Set value of general.useragent.override to "Mozilla/5 [en] ()", mozilla boots
fine.
3.

Actual Results:   See above.

Expected Results:   Would be nice if Mozilla would execute and allow me to
pretend to be Navigator 4.75.

 Alot of web sites still disallow Mozilla (like my Bank!), they allow Netscape
Navigator 4.x though. I need to be able to pretend to be Navigator 4.x.
Pretending to be Explorer doesn't work, If I do I get an explorer only
("extentions") version of the page I need.
What's the error you get?  And do you have the Java plugin?  

*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Comments from reporter:

---------------------------
 INTERNAL ERROR on Browser End: Expected a version > 5! Version = 4

 System error?:: No such file or directory
--------------------------

  And yes, the java plugin is installed.

Verified duplicate. Basically, the java plugin sucks and crashes in this
case....
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.