Closed Bug 1112855 Opened 9 years ago Closed 9 years ago

[tabs tray] Closing last tab behavior doesn't match phone behavior

Categories

(Firefox for Android Graveyard :: Theme and Visual Design, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: liuche, Assigned: mhaigh)

References

Details

a) Closing the last private tab on phones will switch you to normal tab mode, and open one of your ordinary tabs. On tablet, this just closes the tab and doesn't switch you anywhere. I'm not sure that our behavior is necessarily to open one of your open tabs, but it should at least switch to the normal tabs tray.

b) Trying to close the last (non-private) tab will show the title of the tab switching between about:home and Firefox Home, which isn't good UI.
Low priority, but if you've got a few cycles, Martyn.
Assignee: nobody → mhaigh
Status: NEW → ASSIGNED
In response to part a of this bug: I actually quite like that it doesn't try to switch you back to the normal tabs tray.  I can't think of a compelling reason we should be changing back to the normal tab section after the last private tab has been closed - it's not expected behaviour, it's not communicated anywhere that this should happen and requires the user to consciously think about what they are doing. I'd even go so far as to think that the old behaviour could be quite annoying.  

antlam : what are your thoughts?

in response to part b: I agree that feels a bit janky
Flags: needinfo?(alam)
(In reply to Chenxia Liu [:liuche] PTO through 1/11/2015 from comment #0)
> a) Closing the last private tab on phones will switch you to normal tab
> mode, and open one of your ordinary tabs. On tablet, this just closes the
> tab and doesn't switch you anywhere. I'm not sure that our behavior is
> necessarily to open one of your open tabs, but it should at least switch to
> the normal tabs tray.

I think switching to a tab gets kind of in the way and isn't particularly useful nor a pain (if I have to tap the tab myself).

> b) Trying to close the last (non-private) tab will show the title of the tab
> switching between about:home and Firefox Home, which isn't good UI.

Agree as well.

(In reply to Martyn Haigh (:mhaigh) from comment #2)
> In response to part a of this bug: I actually quite like that it doesn't try
> to switch you back to the normal tabs tray.  I can't think of a compelling
> reason we should be changing back to the normal tab section after the last
> private tab has been closed - it's not expected behaviour, it's not
> communicated anywhere that this should happen and requires the user to
> consciously think about what they are doing. I'd even go so far as to think
> that the old behaviour could be quite annoying.  
> 
> antlam : what are your thoughts?
> 
> in response to part b: I agree that feels a bit janky

Yeah, it does seem awkward that the closing the last tab triggers a completely different action than closing the other tabs. On the other hand, I do see how after someone closes all their private tabs, we assume they would probably just want to go back to their normal tabs anyways, but the experience feels very jarring ATM.

Either way, I think we should keep the tablet and phone behavior consistent. I think that closing the last private tab should probably not open some normal tab.

So, two proposals. 

A) Closes last private tab -> stay in empty private tabs tray
B) Closes last private tab -> move to normal tabs tray

Before we decide, do we have telemetry on any of this stuff?
Flags: needinfo?(alam)
antlam: "our telemetry around private browsing is poor deliberately" - rnewman
After discussion with antlam and mcomella, we decided that switching to the normal tabs tray (B) felt like the best way forwards here.  

We're going to keep this functionality just on tablet atm
Having implemented this, I don't think it's right.  The change is too sudden - there's no indication that the tab is going to change and it's actually quite difficult to spot what has happened.

APK: https://mega.co.nz/#!dlhVHKzD!OrqX9KVBoavh51bXuiHHL4KfVy8HraPDatWWPZ8uk9w

Example: switch to private tabs and open one private tab, go back in to the tabs tray and then close the private tab - the result is that it appears that the tab didn't close.

I'm erring on keeping the existing functionality for this issue.
Flags: needinfo?(michael.l.comella)
Flags: needinfo?(alam)
Your build crashes on startup for me:

java.lang.ClassNotFoundException: Didn't find class "org.mozilla.gecko.tabs.TabPanelBackButton"

Looks like an hg queue issue. Can you pop up another one?
Flags: needinfo?(michael.l.comella)
Flags: needinfo?(mhaigh)
Flags: needinfo?(alam)
odd - new one here: https://mega.co.nz/#!A4QjhLDZ!mFT4VmZVZtcWWLtRYd926PujSRUTXwmemA1Y2AsywlY
Flags: needinfo?(mhaigh)
Flags: needinfo?(michael.l.comella)
Flags: needinfo?(alam)
moz.build issue was causing that ClassNotFoundException.

New APK : https://mega.co.nz/#!gxp1GKgZ!uG0fVLxzu8TZt9yk1j_lf0-1y3Zgc-d9YlJdiGPVHKY
Ack - sorry, getting my builds in a mess today - this APK should work: https://mega.co.nz/#!sgRR3Z7Y!QC8g31n0cmGkxmcYfaW4pZNcMmXJZOA10tq17m60ZQw
From our discussion,

If the user closes the last private tab, they should stay in the empty private tabs tray.

If the user closes the last normal tab, they should stay in the normal tabs tray. They should always have at least 1 normal tab.
Flags: needinfo?(alam)
Flags: needinfo?(michael.l.comella)
We've decided to keep existing functionality for the moment
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.