Closed Bug 11129 Opened 21 years ago Closed 21 years ago

Browser window resizes itself after loading a page

Categories

(SeaMonkey :: General, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED INVALID

People

(Reporter: cpratt, Assigned: don)

References

()

Details

(Whiteboard: [TESTCASE])

Attachments

(1 file)

Build ID: 1999080208 (Win32), 1999080212 (Linux)
Platform: Windows NT, Linux (Mac OS will be investigated later)

To reproduce:
- Launch apprunner
- Load the above URL

Result: The window automatically resizes itself to fit the page.

Expected result: The window remains the same size and scrollbars are drawn to
allow you to see the entire page.
QA Contact: leger → cpratt
Attached file testcase
Whiteboard: [TESTCASE]
The following javascript code is the cause of the resize:

if (((parseInt(navigator.appVersion) >= 4 )) &&
    ((screen.availWidth >= 800) && (screen.availHeight >= 600)))
        {
        self.resizeTo(795, 595);
        }

The window is resized using Communicator 4.08 also.

I think this is what the author of that page intended to happen.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
Didn't see it happening in Communicator 4.7 beta... but this bug is starting to
sound like it's invalid to me! Marking invalid & verifying. Thanks, mats!
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.