adbhelper 0.7.2 add-on breaks session restore

RESOLVED DUPLICATE of bug 1113539

Status

DevTools
WebIDE
RESOLVED DUPLICATE of bug 1113539
4 years ago
a month ago

People

(Reporter: Alexander Ploumistos, Unassigned)

Tracking

34 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141201111703

Steps to reproduce:

I was looking to report this against Devtools, but couldn't find the right component.

This morning, I started firefox and I got a single new tab. In the History menu, "Recently Closed Tabs" and "Recently Closed Windows" were greyed out.

I am using Firefox (firefox-34.0-1.fc20.x86_64) on 64-bit Fedora 20.


Actual results:

I have set Firefox to "Show my windows and tabs from last time" on startup, but even though I had a few tab groups with a large number of tabs in each one, none of them opened. I proceeded to open a few tabs, pinned some of them and then closed Firefox. When I started it again, I got a single new page and no access to my previous tabs or windows. I repeated the process another 3 times - same result.

I checked my system logs and noticed this line, appearing 5 times since last night:

gnome-session[1798]: ols.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < devtools.require<@main.js:18:12 < @main.js:23:29 < startup@file:///home/<user>/.mozilla/firefox/<my_ff_folder>.default/extensions/adbhelper@bootstrap.js:89:16 < XPI_callBootstrapMethod@XPIProvider.jsm:4305:9 < XPI_startup@XPIProvider.jsm:1968:13 < callProvider@AddonManager.jsm:208:12 < _startProvider@AddonManager.jsm:667:5 < AMI_startup@AddonManager.jsm:821:9 < AMP_startup@AddonManager.jsm:2399:5 < AMC_observe@addonManager.js:55:7

Then I checked the extension folder/script mentioned in the log:

ls -lh /home/<user>/.mozilla/firefox/<my_ff_folder>.default/extensions/adbhelper@mozilla.org/
total 144K
-rw-r--r--. 1 <user> <user> 2.7K Dec 18 01:47 adb-client.js
-rw-r--r--. 1 <user> <user>  34K Dec 18 01:47 adb.js
-rw-r--r--. 1 <user> <user> 1.9K Dec 18 01:47 adb-running-checker.js
-rw-r--r--. 1 <user> <user> 2.8K Dec 18 01:47 adb-socket.js
-rw-r--r--. 1 <user> <user> 2.7K Dec 18 01:47 bootstrap.js
-rw-r--r--. 1 <user> <user> 1.1K Dec 18 01:47 install.rdf
drwxr-xr-x. 2 <user> <user> 4.0K Dec 18 01:47 linux64
-rw-r--r--. 1 <user> <user> 4.1K Dec 18 01:47 main.js
-rw-r--r--. 1 <user> <user> 6.6K Dec 18 01:47 scanner.js
-rw-r--r--. 1 <user> <user>  53K Dec 18 01:47 subprocess.js
-rw-r--r--. 1 <user> <user> 8.9K Dec 18 01:47 subprocess_worker_unix.js

I do not recall explicitly installing it and judging by the timestamps, it was installed last night.

I opened firefox again, went to the Add-ons tool and disabled adbhelper (it was last updated on 12/18/2014). Upon restarting Firefox, I was offered to restore my session from last night, which I did. All tabs and groups were back, but no sign of the others I had randomly opened in between the sessions.



Expected results:

(Firefox should have restored my previous session)

Comment 1

4 years ago
It even seems to destroy more. *undo close tab does not work* anymore. *Browser console* (ctrl+shift+k) not, also not from the extras, web dev menu. 

Disabling this new mysterious addon helps (needs a restart).  Enabling an restarting brings back the symtoms.

I just wrote on input.mozilla.org: "sad" - there is a "ADB Helper" which looks like it was inserted by malware. Probably just another bloatfox thing. Bad info available! Only a link to the github repository.

Comment 2

4 years ago
edit: I am using Firefox 34.0.5 on 64 bit Linux. The addon was written at 17. Dec, 23:42 (UTC) into my profile (... /extensions/adbhelper@mozilla.org/ ).

Comment 3

4 years ago
Some more info: in a fresh profile I did not have this extension.

It got pulled in as soon I started Firefox' WebIDE - clearly visible (along with many WARN about exceptions).

I did not have problems to undo close tab - even after a restart. So, I guess this unwanted addon interferes with one of my other Firefox addons. That may be even that other addon's fault, however, Mozilla should just not pull in a addon which I never wanted (and not even providing info about the addon  - why it is there, who put it there...). 

Sorry guys, that really went wrong (whatever good intentions you had).

Comment 4

4 years ago
Apparently this is THE info page about this addon https://developer.mozilla.org/en-US/Firefox_OS/Using_the_App_Manager
Sorry for the trouble this has caused.  The addon implements part of the functionality of WebIDE: connecting to devices.

Anyway, I'm about to revert the cause of this issue in an update for the addon.  See bug 1113539.
Depends on: 1113539
Component: General → Developer Tools: WebIDE
Product: Core → Firefox
(Reporter)

Comment 6

4 years ago
After checking for updates, I've got ADB Helper 0.7.3. Is that the one?
(In reply to alexpl from comment #6)
> After checking for updates, I've got ADB Helper 0.7.3. Is that the one?

Yes, does that resolve the problems you are seeing?
Flags: needinfo?(alexpl)
(Reporter)

Comment 8

4 years ago
Yes, after enabling it and restarting firefox a couple of times I get my session back as it was.

Thank you
Flags: needinfo?(alexpl)
(In reply to alexpl from comment #8)
> Yes, after enabling it and restarting firefox a couple of times I get my
> session back as it was.
> 
> Thank you

Great, I'm glad to hear that!

Once again, sorry for the trouble!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
No longer depends on: 1113539
Resolution: --- → DUPLICATE
Duplicate of bug: 1113539

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.