If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

MP Feedback is not sent

VERIFIED FIXED in 2015-01-06

Status

Marketplace
Consumer Pages
P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Madalin Cotetiu, Assigned: ashort)

Tracking

Avenir
2015-01-06
x86_64
Windows 7
Points:
---

Details

(URL)

(Reporter)

Description

3 years ago
Steps to reproduce:
1. Open MP-homepage https://marketplace.allizom.org/ and log in
2. Hover over the gear icon and click the Feedback link
3. Enter a text and click the Send button.
4. Check the Fake Email page: https://marketplace.allizom.org/admin/mail

Expected results:
The feedback is sent.In fake mail page there is a log regarding the sent message.

Actual results:
In fake mail page there is no log regarding the sent feedback message. 
Also when using a yahoo mail account the following message is received:

----- Forwarded Message -----

This is the mail system at host socketlabs-relay1.webapp.phx1.mozilla.com.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                  The mail system

<apps-feedback@mozilla.com>: host ASPMX.L.GOOGLE.com[74.125.20.27] said:
    550-5.7.1 Unauthenticated email from yahoo.com is not accepted due to
    domain's 550-5.7.1 DMARC policy. Please contact administrator of yahoo.com
    domain if 550-5.7.1 this was a legitimate mail. Please visit 550-5.7.1
    http://support.google.com/mail/answer/2451690 to learn about DMARC 550
    5.7.1 initiative. gy1si10344538pbd.94 - gsmtp (in reply to end of DATA
    command)

Notes/Issues:
Verified in FF37(Win7). Issue can be reproduced in MP-stage.
Screencast for this issue http://screencast.com/t/i3ONxuxPBjMv

Comment 1

3 years ago
It's worth noting that on stage, we run the emails through an approval list, so they'll never appear in the fake mail page.

So with the move to Google for our email, they are now checking the from address for emails if a user is signed in. That's because we from email is set to the users email, we should be setting the reply-to header instead and check the Google won't try and confirm that.
Assignee: nobody → ashort
Priority: -- → P1
(Assignee)

Updated

3 years ago
Target Milestone: 2014-12-16 → 2014-12-30
(Assignee)

Comment 2

3 years ago
https://github.com/mozilla/zamboni/commit/fb764c4a9828f3612e172b830841dec1962f7879
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Target Milestone: 2014-12-30 → 2015-01-06
CCing dbialer to make him aware of this.  It may be causing a drop in feedback reports until this patch goes out.
(Reporter)

Comment 4

3 years ago
Verified as fixed in mp-dev and mp-stage.
Closing.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.