Closed Bug 11133 Opened 21 years ago Closed 21 years ago

content type shouldn't contain charset (or version) information

Categories

(Core :: Networking, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: vidur, Assigned: rpotts)

References

()

Details

Currently Necko doesn't strip out charset (and probably version) information
from the content type field in the HTTP header. As a result, existing code in
the DocLoader that expects the content type to just be the mime type information
will fail when looking for the appropriate content viewer.
Blocks: 7585
Target Milestone: M9
Related to bug 8443.
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
I've checked in a fix for this as part of the header API changes...

-- rick
*** Bug 10627 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
verified fixed
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.