Links to add sender/recipient in mail msg summary bar ignore color prefs.

RESOLVED INVALID

Status

RESOLVED INVALID
17 years ago
14 years ago

People

(Reporter: carlalex, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112012

In the the per-message summary bar that appears between the threaded list of
messages and the full text of the current message, the sender and recipients are
displayed as links to allow easy integration with the address book. The problem
is the color of these links always seems to be "Netscape Default link blue", not
the "Unvisited link" color from Prefs->Appearance->Colors nor anything from my
gtk+ configuration.  The problem? This shade of blue is un-readable with some
GTK+ configurations (I happen to prefer light on dark).  I've included my
~/.gtkrc for your ammusement and testing from my Redhat 7.0 box.

Additional notes: While I think this link color should be adjustable, It may not
be appropriate to take the link color from the Links prefs in the appearance
manager since the background of this widget seem to be taken from GTK defaults
rathar than appearance manager defaults.



Reproducible: Always
Steps to Reproduce:
1. Install my ~/.gtkrc
2. restart mozilla
3. run mail reader.

Actual Results:  colors resulted in un-readable message summary.

Expected Results:  Links should be in a readable color.


My ~/.gtkrc


style "LightOnDark"
{
  font = "-*-lucida-medium-r-normal-*-*-140-*-*-p-*-iso8859-1"
  fg[NORMAL]      = { 0.88, 0.88, 0.88 }
  fg[PRELIGHT]    = { 1.00, 1.00, 1.00 }
  fg[ACTIVE]      = { 1.00, 1.00, 1.00 }
  fg[SELECTED]    = { 0.88, 0.88, 0.88 }
  fg[INSENSITIVE] = { 0.88, 0.88, 0.88 }

  bg[NORMAL]      = { 0.20, 0.22, 0.35 }
#  bg[PRELIGHT]    = { 0.2, 0.2, 0.2 }
  bg[PRELIGHT]    = { 0.6, 0.5, 0.3 }
  bg[ACTIVE]      = { 0.3, 0.3, 0.6 }
  bg[SELECTED]    = { 0.1, 0.1, 0.1 }
  bg[INSENSITIVE] = { 0.1, 0.1, 0.1 }

  base[NORMAL]      = { 0.25, 0.27, 0.35 }
  base[PRELIGHT]    = { 0.2, 0.2, 0.2 }
  base[ACTIVE]      = { 0.3, 0.3, 0.3 }
  base[SELECTED]    = { 0.1, 0.1, 0.1 }
  base[INSENSITIVE] = { 0.1, 0.1, 0.1 }

}

style "DarkOnLight"
{
  font = "-*-lucida-medium-r-normal-*-*-140-*-*-p-*-iso8859-1"
  bg[NORMAL]      = { 0.70, 0.70, 0.70 }
  bg[PRELIGHT]    = { 0.70, 0.70, 0.90 }
  bg[ACTIVE]      = { 0.80, 0.80, 0.90 }
  bg[SELECTED]    = { 0.70, 0.70, 0.70 }
  bg[INSENSITIVE] = { 0.70, 0.70, 0.70 }

  fg[NORMAL]      = { 0.15, 0.17, 0.25 }
  fg[PRELIGHT]    = { 0.2, 0.2, 0.2 }
  fg[ACTIVE]      = { 0.3, 0.3, 0.3 }
  fg[SELECTED]    = { 0.1, 0.1, 0.1 }
  fg[INSENSITIVE] = { 0.1, 0.1, 0.1 }

  base[NORMAL]      = { 0.75, 0.77, 0.80 }
  base[PRELIGHT]    = { 0.80, 0.80, 0.80 }
  base[ACTIVE]      = { 0.70, 0.70, 0.70 }
  base[SELECTED]    = { 0.90, 0.90, 0.80 }
  base[INSENSITIVE] = { 0.90, 0.90, 0.90 }
}

style "edit"
{
  font = "-*-lucida-medium-r-normal-*-*-140-*-*-p-*-iso8859-1"
  fg[NORMAL]      = { 0.88, 0.88, 0.88 }
  fg[PRELIGHT]    = { 1.00, 1.00, 1.00 }
  fg[ACTIVE]      = { 1.00, 1.00, 1.00 }
  fg[SELECTED]    = { 0.88, 0.88, 0.88 }
  fg[INSENSITIVE] = { 0.88, 0.88, 0.88 }

  bg[NORMAL]      = { 0.20, 0.22, 0.35 }
#  bg[PRELIGHT]    = { 0.2, 0.2, 0.2 }
  bg[PRELIGHT]    = { 0.6, 0.5, 0.3 }
  bg[PRELIGHT]    = { 0.6, 0.5, 0.3 }
  bg[ACTIVE]      = { 0.3, 0.3, 0.6 }
  bg[SELECTED]    = { 0.1, 0.1, 0.1 }
  bg[INSENSITIVE] = { 0.1, 0.1, 0.1 }

  base[NORMAL]      = { 0.925, 0.27, 0.35 }
  base[PRELIGHT]    = { 0.2, 0.2, 0.2 }
  base[ACTIVE]      = { 0.3, 0.3, 0.3 }
  base[SELECTED]    = { 0.1, 0.1, 0.1 }
  base[INSENSITIVE] = { 0.1, 0.1, 0.1 }

}


class "GtkWidget" style "LightOnDark"
class "GtkEditable" style "DarkOnLight"
(Reporter)

Comment 1

17 years ago
As an after thought... This problem also seems to afflict the link text of items
in my "links" toolbar at the top of the browser window when they are in a "mouse
over" state.  Don't know if it's the exact same problem, but I'd expect it to be
a simmilar gtk+ widget/ defautlts problem.

Comment 2

17 years ago
How does it conflict with the gtk color theme?
Mozilla uses the colors from the theme and not any from GTK last I checked.

Comment 3

17 years ago
It doesn't make sense to have the link colors apply to mailnews as well because
in the browser, the background is colored using the default document color set
in preferences while the background in that area of mailnews is set by the theme
and thus the theme should have control over it.

It doesn't really make sense for the perference to change color of mailnews
links at the same time.

I'm sure you can do that manually using a custom style ...

Comment 4

17 years ago
Marking invalid (from above comment).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
OS: Linux → All
Hardware: PC → All
Resolution: --- → INVALID

Comment 5

17 years ago
The reporter is asking for a new feature, not reporting a bug.

Example: Use CLASSIC theme, email header in question uses colours Blue & Red.
Use MODERN theme, email header uses colours Grey & Light Blue. 

This setting is theme controled and has nothing to do with the preference stated
in the report. Personally, I disagree with the reporter since I do not think
this is an element the user should not have control over, beyond downloading a
theme he or she likes.

Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.