Add Autogenerated Lists in LDAP to sync to google

RESOLVED FIXED

Status

Infrastructure & Operations
Infrastructure: LDAP
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jen, Assigned: jabba)

Tracking

Details

(Reporter)

Description

3 years ago
Autogenerated lists:
all-moco@mozilla.com:  anyone with a moco address
all-mofo@mozilla.com:  anyone with a mofo address
all-moco-mofo@mozilla.com:  all-moco & all mofo

Alias: all-mofo-moco@mozilla.com to all-moco-mofo@mozilla.com

Also - we'd like to replace the everbody@mozilla.com in Google.
(Reporter)

Comment 1

3 years ago
Also - we'd like to replace the everbody@mozilla.com in Google with everybody@mozilla.org.  But I'll need to coordinate to do that.
(Assignee)

Comment 2

3 years ago
Now is probably a good time to define exactly who should be on these lists. For moco, do we just want @mozilla.com, or also @mozilla-japan.org, since those are both in the same org in LDAP.. For Mofo, I'm assuming all @mozillafoundation.org e-mails. I'd propose that we ignore any @mozilla.org e-mails, since those are scattered around o=com, o=org and o=net randomly and are usually not employees.

We also need to know where the current all-moco-mofo list is. Is that a mailman list that gets autogenerated?

Should everybody@mozilla.com just be an alias to all-moco-mofo as well?
Flags: needinfo?(jhayashi)
(Assignee)

Comment 3

3 years ago
rtucker just found this: https://support.google.com/a/answer/66338?hl=en It might be the more appropriate action to take here.
(Reporter)

Comment 4

3 years ago
Hi Jabba - so I did create a list called everybody@mozilla.com with the dynamic list mentioned in comment 3.  But the problem is that no one likes that it's @mozilla.com.   I'll need some help to get everybody@mozilla.org into Google
Flags: needinfo?(jhayashi)
(Assignee)

Comment 5

3 years ago
can limed just create a forwarder/alias in postfix to send everyone@mozilla.org to everyone@mozilla.com ?
(Reporter)

Comment 6

3 years ago
jabba; we can't just forward because Mardi and crew like to send calendar invites to these lists.  If the lists don't live in  Google then the Google invites stop working.
(Reporter)

Comment 7

3 years ago
Here's the new proposed solution:

everyone@mozilla.com (Use https://support.google.com/a/answer/66338?hl=en)
everyone@mozilla.org is an alias for everyone@mozilla.com
all-moco-mofo@mozilla.com is an alias for everyone@mozilla.com

Get rid of all-moco@mozilla.com  
Get rid of all-mofo@mozilla.com 

Any thoughts?
Flags: needinfo?(mdouglass)
Flags: needinfo?(jdow)

Comment 8

3 years ago
So, I'm not sure I feel strongly about what the DLs are but rather what they do. Here's what I need:

1. The ability to communicate to just moco peeps (we can include Japan since they are in there now).
2. The ability to communicate with just mofo peeps
3. The ability to communicate with both at once (and I'm totally okay to have to use two aliases).
4. The ability to invite the above to meetings + to view a Google cal.

So, I don't think we can get rid of all-moco / all-mofo, can we?
(Reporter)

Comment 9

3 years ago
Per our meeting with justdave:

everyone@mozilla.org - is a postfix alias to all-moco-mofo in mailing list. 
membership is autogenerated;  Script is for mailman3 in Zimbra module in puppet called mailman.list.py

Jabba will work on getting all-moco-mofo in LDAP.  he will update the list to also have an inclusion list of people who might not be part of the query but should be added anyway.  And an exclusion list to remove the shared and vendor accounts.
(Assignee)

Comment 10

3 years ago
I've moved the auto-generated lists to LDAP/google. We currently have all-moco-mofo@mozilla.com, all-moco@mozilla.com and all-mofo@mozilla.com in google, and they are set to internal-only, meaning only members can post to them. They currently have no aliases. I need to know which aliases to add to them.
Flags: needinfo?(jdow) → needinfo?(jhayashi)
(Reporter)

Comment 11

3 years ago
Hi Mardi -

The only thing we're missing is the aliases.  Can you tell me which ones we want to keep?  I think we want to prune out as much as we can.  But I'm thinking:

all-mofo-moco@mozilla.com --> all-moco-mofo@mozilla.com (so that people don't have to remember the order)
everyone@mozilla.org --> all-moco-mofo@mozilla.com

All the others - everybody@, all@ and anything else I'm missing goes away.  What do you think?
Flags: needinfo?(jhayashi) → needinfo?(mardi.douglass)

Comment 12

3 years ago
So, we have two aliases that do the same thing:

1) everyone@mozilla.org
2) all-moco-mofo@mozilla.com

Do we need both?

Also, want to make sure we have all-moco@mozilla.com AND all-mofo@mozillafoundation.org as well.
Flags: needinfo?(mdouglass)
I think it'd be less confusing to make everyone@mozilla.org go away.  It was a legacy name, and currently we're being tripped up by the fact that mozilla.org is not hosted on Google, which breaks calendar invites.  The safe thing to do is probably force everyone to use all-moco-mofo and just nuked everyone@.

Comment 14

3 years ago
I'm all for making the fewest possible options.
(Assignee)

Comment 15

3 years ago
I think this is done already and we just didn't close the bug.
Assignee: infra → jdow
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(mardi.douglass)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.