Move HtmlForm.properties out of communicator chrome

RESOLVED DUPLICATE of bug 279768

Status

()

Core
Layout: Misc Code
RESOLVED DUPLICATE of bug 279768
17 years ago
14 years ago

People

(Reporter: Adam Lock, Assigned: Benjamin Smedberg)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
The following chrome files should be moved out of the communicator package and
into their own place, i.e. a dedicated layout package.

xmlparser.properties
HtmlForm.properties
ImageDocument.properties
The way these files are included in locale/en-US/communicator/layout/ is pretty
ugly too. mozilla/layout would benefit from having a dedicated resource
directory much like mozilla/netwerk.

See bug 63607 & bug 90749 for more info - basically embedding shouldn't have to
include anything from communicator.

Updated

17 years ago
Target Milestone: --- → Future
->Misc Code
Assignee: attinasi → misc
Component: Layout → Layout: Misc Code
QA Contact: petersen → nobody
Note that ImageDocument.properties is now MediaDocument.properties.
Target Milestone: Future → ---

Comment 3

15 years ago
Sorry, which is the mozilla/netwerk referred to?
mozilla/netwerk/resources/*

Comment 5

15 years ago
Gotcha. (notices a communicator URL in netwerk/resources/jar.mn)
So, the idea is to change the references in the source and jar.mn to match?
I think that's the goal, yes...
(Assignee)

Comment 7

15 years ago
OK, I think I can accomplish this at the same time as bug 179834... if we can
support multiple locations for chrome, we can ship these with the GRE instead of
making embedders do that.
Assignee: misc → bsmedberg
(Assignee)

Updated

15 years ago
Depends on: 179834
(Assignee)

Comment 9

15 years ago
OK, if these files were introduced into the GRE (XRE) package, that would cause
the GRE to have language dependencies. I still think they belong in the GRE,
because they are necessary for HTML/XML to render properly, but this means that
we need to ship localizations of the GRE... blech

Comment 10

15 years ago
Um, is stuff like textboxes in the GRE? They have localized context menus...
The context menus are not part of Gecko... these files are.  Perhaps we should
make this a separate part of the GRE somehow, one that's easy to replace?
(Assignee)

Comment 12

15 years ago
Nothing in the GRE is easy to replace ;)

Really, I've been working through a whole set of problems like this one, where
parts of gecko are locale-dependent. We currently use the chrome registry to
accomplish the locale, which is gigantic overkill and isn't what the chrome
registry was designed to do. I want to make the core HTML-rendering aspects of
gecko not need the chrome registry at all. See bug 215212 for my plans to
implement a gecko locale service that will handle the basic locale needs of gecko.

--BDS
(Assignee)

Comment 13

14 years ago

*** This bug has been marked as a duplicate of 279768 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.