Optimize idle thread annotations in workers

RESOLVED FIXED in mozilla37

Status

()

Core
DOM: Workers
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: Ben Turner (not reading bugmail, use the needinfo flag!), Assigned: Ben Turner (not reading bugmail, use the needinfo flag!))

Tracking

Trunk
mozilla37
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Bug 970307 added some idle annotations in the an imperfect spot I think. Hopefully this works the same and will be better.
Comment on attachment 8538871 [details] [diff] [review]
Patch, v1

Review of attachment 8538871 [details] [diff] [review]:
-----------------------------------------------------------------

The previous spot didn't take nested event loops into account either...
Duplicate of this bug: 1113428
Attachment #8538871 - Flags: review?(nfroyd) → review+
https://hg.mozilla.org/mozilla-central/rev/3285d8bef13f
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
Depends on: 1166207
sorry had to back this out in https://treeherder.mozilla.org/#/jobs?repo=b2g-inbound&revision=614d52bca5ac since one of this changes broke ics debug tests with failures like :

https://treeherder.mozilla.org/logviewer.html#?job_id=1958358&repo=b2g-inbound
Flags: needinfo?(cyu)
Canceling NI flag. The bustage is fixed and the change is repushed.
Flags: needinfo?(cyu)
You need to log in before you can comment on or make changes to this bug.