Intermittent browser_webconsole_bug_613280_jsterm_copy.js | A promise chain failed to handle a rejection: - at resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/framework/toolbox.js:1006 - TypeError: panel is undefined

RESOLVED DUPLICATE of bug 1117975

Status

()

Firefox
Developer Tools: Console
RESOLVED DUPLICATE of bug 1117975
3 years ago
3 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
17:02:46 INFO - 3564 INFO TEST-START | browser/devtools/webconsole/test/browser_webconsole_bug_613280_jsterm_copy.js
17:03:09 INFO - WebConsolePanel open failed. timeout: Connection timeout. Check the Error Console on both ends for potential error messages. Reopen the Web Console to try again.
17:03:09 INFO - *************************
17:03:09 INFO - A coding exception was thrown in a Promise resolution callback.
17:03:09 INFO - See https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise
17:03:09 INFO - Full message: TypeError: panel is undefined
17:03:09 INFO - Full stack: Toolbox.prototype.loadTool/onLoad/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/framework/toolbox.js:1006:13
17:03:09 INFO - Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:870:23
17:03:09 INFO - this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:749:7
17:03:09 INFO - this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:691:37
17:03:09 INFO - *************************
17:03:17 INFO - 3565 INFO checking window state
17:03:17 INFO - 3566 INFO Console message: [JavaScript Error: "WebConsolePanel open failed. timeout: Connection timeout. Check the Error Console on both ends for potential error messages. Reopen the Web Console to try again." {file: "resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/webconsole/panel.js" line: 102}]
17:03:17 INFO - 3567 INFO Console message: [JavaScript Error: "Web Console getCachedMessages error: invalid state." {file: "resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/webconsole/webconsole.js" line: 5072}]
17:03:17 INFO - 3568 INFO TEST-UNEXPECTED-FAIL | browser/devtools/webconsole/test/browser_webconsole_bug_613280_jsterm_copy.js | A promise chain failed to handle a rejection: - at resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/framework/toolbox.js:1006 - TypeError: panel is undefined
17:03:17 INFO - Stack trace:
17:03:17 INFO - Toolbox.prototype.loadTool/onLoad/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/framework/toolbox.js:1006:13
17:03:17 INFO - Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:870:23
17:03:17 INFO - this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:749:7
17:03:17 INFO - this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:691:37
17:04:16 INFO - Xlib: extension "RANDR" missing on display ":0".
17:04:18 INFO - TEST-INFO | screentopng: exit 0
17:04:18 INFO - 3569 INFO TEST-UNEXPECTED-FAIL | browser/devtools/webconsole/test/browser_webconsole_bug_613280_jsterm_copy.js | Test timed out - expected PASS
17:04:18 INFO - console.error:
17:04:18 INFO - Panel webconsole:
17:04:18 INFO - Message: TypeError: panel is undefined
17:04:18 INFO - Stack:
17:04:18 INFO - Toolbox.prototype.destroy@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/framework/toolbox.js:1623:9
17:04:18 INFO - DT_closeToolbox@resource:///modules/devtools/gDevTools.jsm:472:12
17:04:18 INFO - tearDown@chrome://mochitests/content/browser/browser/devtools/webconsole/test/head.js:333:3
17:04:18 INFO - Tester.prototype.nextTest<@chrome://mochikit/content/browser-test.js:349:17
17:04:18 INFO - TaskImpl_run@resource://gre/modules/Task.jsm:314:40
17:04:18 INFO - TaskImpl@resource://gre/modules/Task.jsm:275:3
17:04:18 INFO - createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:249:14
17:04:18 INFO - timeoutFn@chrome://mochikit/content/browser-test.js:743:9
17:04:18 INFO - 3570 INFO TEST-OK | browser/devtools/webconsole/test/browser_webconsole_bug_613280_jsterm_copy.js | took 90322ms
Comment hidden (Treeherder Robot)
(Reporter)

Updated

3 years ago
See Also: → bug 1117975
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1117975
You need to log in before you can comment on or make changes to this bug.