Opening a new tab from context menu item of "Share on Twitter 0.45" is blocked since Nightly of 2014-11-18

RESOLVED INVALID

Status

()

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: masayuki, Unassigned)

Tracking

({regression})

Trunk
x86_64
Windows 8.1
regression
Points:
---

Firefox Tracking Flags

(firefox36-, firefox37-)

Details

FYI: You don't need twitter account for testing this.

1. Install Share on Twitter 0.45 from https://addons.mozilla.org/en-US/firefox/addon/tweetright/?src=external-bn
2. Right click on a web page (open contextmenu)
3. Click "Share on Twitter"

EXPECTED:

Open a window/tab to tweet about the page.

ACTUAL:

The window/tab is blocked by popup blocker.

The regression range is:

Last good revision: a52bf59965a0 (2014-11-17)
First bad revision: 084441e904d1 (2014-11-18)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a52bf59965a0&tochange=084441e904d1

[Tracking Requested - why for this release]:

If this is unexpected bug and should be fixed by Firefox side, this should be fixed for add-on compatibility. This might be occur with other add-ons.
tracking-firefox37: ? → +
Not tracking. This plugin is not very popular and we won't block the release for this bug.
Jorge, what would be the best course of action on this bug? Thanks.
tracking-firefox36: ? → -
Flags: needinfo?(jorge)
This looks like something that needs to be fixed on the add-on side. There are many ways to open windows without triggering the popup blocker. I'll notify the developer about this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(jorge)
Resolution: --- → INVALID
Clearing status and tracking for this invalid bug.
status-firefox34: unaffected → ---
status-firefox35: unaffected → ---
status-firefox36: affected → ---
status-firefox37: affected → ---
tracking-firefox37: + → -
You need to log in before you can comment on or make changes to this bug.