Firefox Accounts sign-in page doesn't reflect the language version of Firefox (location based?)

RESOLVED WORKSFORME

Status

Cloud Services
Server: Firefox Accounts
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: jarda, Assigned: zaach)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141127110656

Steps to reproduce:

Register to Hello from English version of Firefox while sitting in Brussels.


Actual results:

Hello decided to talk in French despite the fact that my Linux, as well as Firefox, talk exclusively English.


Expected results:

Hello should talk English, as my OS and Firefox does, it shouldn't decide without asking, acording to some unknown criteria (Locales? Geolocation? What would happen if I move to Thailand? I can't read Thai.)

Updated

4 years ago
Component: Untriaged → General
Product: Firefox → Loop
QA Contact: anthony.s.hughes
Version: 34 Branch → unspecified
I'm sorry, I do not understand this bug report. Can you please try to explain it in more details?
What I understood is that his Firefox Hello was in French instead of English.
We don't have any geolocation to choose the locale.

Firefox Hello client is part of Firefox so if your all Firefox is in English, then you shouldn't have it in French.

Could you please send us a screenshot so we can have a look at which part of Firefox Hello talk French to you? Also can you give us the result of you going to this page: https://loop.services.mozilla.com/
Flags: needinfo?(jarda)
Having a screenshot of or the list of languages in Options (or preferences) -> Content -> Languages -> Choose would also be helpful.

https://hello.firefox.com/ uses navigator.language to determine the language selection.
(Reporter)

Comment 4

4 years ago
Sorry for the delay, I was away in France and then Ireland, where Hello talked to me consistently in English. Back in Belgium it kept on talking English, which, as far as I remember, wasn't the case before - but after that long I'm not sure which things were in French and which in English.

But when I log off and try to login back again, I'm put onto a login window which is in French, after login Hello talks English.

I tried to log off, restart FF and click the smiley, but the dialogue is in English now. I tried renaming my profile and starting afresh, but the dialogue is still in English.

So I tried creating another account and the whole process is in French, up to the verification email, which starts with the words "Almost there" but then keeps on in French. The verification page in Firefox after opening the link from the verification mail is in French too.

My language setting are: 1. English [en], 2. French [Fr]. When I remove French from the list, the sign in dialogue is in English. But as French is only my second language in the list, I don't see why things should switch to French, if in addition, after signing in it keeps on in English.
Flags: needinfo?(jarda)
I think we need to make a distinction between the parts of the UI that you are using.

- When you click the smiley face, we call that the "panel", this should always be in the same language as the rest of your Firefox.

- When you click sign-in, you get a new tab opened, which lets you sign in or sign up. I could perceive that this is in a different language - but I'd need to confirm.

Can you clarify which you are seeing is changing language please?

Also, if there's other parts of Hello that you are seeing with the wrong language, can you explain which bits they are as well please?
Flags: needinfo?(jarda)
(Reporter)

Comment 6

4 years ago
OK, here it is again, using the correct terms:

The Panel: Now it is in English (English [en] is my first language selected for Content in Firefox)

The Sign-in tab: Is and was in French for no obvious reason. French/France [fr-fr] is selected as my second language - I would expect the sign-in tab in French only in the case when English version doesn't exist, which doesn't apply, because English version exists. The sign-in tab reads: "Connexion, Continuer vers Firefox Hello" etc. all in French. I wonder what would happen if my second language was e.g. Mandarin.
Thanks for the response, I'm moving this to the Firefox Accounts component, as I think this is related to the sign-in tab of Firefox Accounts.
Component: General → Server: Firefox Accounts
Flags: needinfo?(jarda)
Product: Loop → Mozilla Services
Summary: Hello doesn't respect language version of Firefox → Firefox Accounts sign-in page doesn't reflect the language version of Firefox (location based?)
Yes, I can repro if the first language is "en", and second one is "fr-fr".
Assignee: nobody → zack.carter
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
I can't reproduce this against the latest FxA server, so I'm going to close it out.  It may be that we're now e.g. doing a better job of handling "en" as an explicit language rather than allowing it to fall back to "en-US".  Please re-open if this is still a problem for you.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.