Require LDAP access to tableau_users

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: tspurway, Assigned: Usul)

Tracking

Details

(Reporter)

Description

4 years ago
This is for Content Service reporting.  If it isn't too much trouble or expense, we should grant access to everyone in Content Services to these reports.  At the very least, everyone on the CC list.

Updated

4 years ago
Assignee: server-ops → nobody
Component: Account Requests → MOC: Service Requests
QA Contact: moconnor → dmoore
(Assignee)

Comment 1

4 years ago
Sheeri can you approve ?
Flags: needinfo?(scabral)
(Assignee)

Updated

4 years ago
Assignee: nobody → ludovic
Yes, I approve of all these folks having their tableau_users ldap bit set.
Flags: needinfo?(scabral)
(Assignee)

Comment 3

4 years ago
edilee@mozilla.com is not a LDAP account what is the ldap account ?

All others have been added to cn=tableau_users,ou=groups,dc=mozilla.
Flags: needinfo?(tspurway)
Flags: needinfo?(edilee)
My ldap is elee@
Flags: needinfo?(edilee)
(Assignee)

Comment 5

4 years ago
(In reply to Ed Lee :Mardak from comment #4)
> My ldap is elee@

Thanks. Added. Sorry for the delay.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(tspurway)
Resolution: --- → FIXED
(Reporter)

Comment 6

4 years ago
I (tspurway@mozilla.com) still don't have access to the Tableau server page.  When I go to the URL:

https://dataviz.mozilla.org/views/Tiles-ContentServices/TilesbyMeasures

and enter my LDAP user/pass I get the same error:

Sorry, it looks like you're not in the "tableau_users" LDAP group needed to access Tableau. Please submit a bug under "Server Operations: Account Requests: to be added to this group.
You are going to be logged in as a guest now but please do not forget to put in a bug requesting your own access.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
When I access the datavis TilesbyMeasures workbook, I enter my LDAP and see a in-content login with a default Username of read_only. Is this somewhat expected as it seems like I'm correctly set for tableau_users, but perhaps a separate connection is not quite configured correctly?
Ludo, can you make sure they're added into the group? I have heard the UI is tricky and that it's easy to forget to submit the change. see comment 6, and please re-check everyone.
Ed - that means that the password is not embedded in the graph itself. Josephine, is this a security measure or something we will get rid of after testing?
Flags: needinfo?(ludovic)
Flags: needinfo?(jtanumijaya)

Comment 10

4 years ago
Hi Ed, that means you have access to tableau server but there is another layer of access into the underlying database (username: read_only).

I have embedded the password in the data so it will not prompt you for password on read_only anymore. Can you click on the link again? This also means the dashboard can be accessed by all "tableau_users" LDAP group. 

Can I get a list of the people who can access this particular dashboard? I will then add each individual to access the dashboard. Other tableau_users will not be able to access it.

Another note for Ed, the dashboard is currently slow (it's trying to show 700M rows of data). If it's getting too long to load, try clicking the refresh button on the url address. I'm currently working with Tim to improve the performance.

Thanks,
Josephine
Flags: needinfo?(jtanumijaya)
(Assignee)

Comment 11

4 years ago
(In reply to Sheeri Cabral [:sheeri] from comment #8)
> Ludo, can you make sure they're added into the group? I have heard the UI is
> tricky and that it's easy to forget to submit the change. see comment 6, and
> please re-check everyone.

Indeed tim wasn't in the group.
Flags: needinfo?(ludovic)
(Assignee)

Comment 12

4 years ago
Ed are your issue fixed. Sorry for the dealy I still need to configure my bugmail.
(Reporter)

Comment 13

4 years ago
Hi Ludo, this is definitely better than it was, I get to the big orange button to "Create Account", but get an error on click:

Oops! Ran into a speed bump: exception 'Exception' with message 'Unable to login to Tableau Server: ' in C:\wamp\www\functions.php:334 Stack trace: #0 C:\wamp\www\add_user.php(12): add_tableau_user('tspurway@mozill...', 'rgpqfvgsBARcD1i...', 'Tim Spurway', 'interactor', 'none', '1', 0) #1 {main}Oops! Ran into a speed bump: exception 'Exception' with message 'Add user failed :(' in C:\wamp\www\add_user.php:12 Stack trace: #0 {main}

Why not checkout this video while you wait?
Tableau Server Demo
Flags: needinfo?(ludovic)
(Reporter)

Updated

4 years ago
Blocks: 1110456
(Assignee)

Comment 14

4 years ago
(In reply to Tim Spurway [:tspurway] from comment #13)
> Hi Ludo, this is definitely better than it was, I get to the big orange
> button to "Create Account", but get an error on click:
> 
> Oops! Ran into a speed bump: exception 'Exception' with message 'Unable to
> login to Tableau Server: ' in C:\wamp\www\functions.php:334 Stack trace: #0
> C:\wamp\www\add_user.php(12): add_tableau_user('tspurway@mozill...',
> 'rgpqfvgsBARcD1i...', 'Tim Spurway', 'interactor', 'none', '1', 0) #1
> {main}Oops! Ran into a speed bump: exception 'Exception' with message 'Add
> user failed :(' in C:\wamp\www\add_user.php:12 Stack trace: #0 {main}
> 
> Why not checkout this video while you wait?
> Tableau Server Demo

that's something for the data team to look at because it's the application level.
Flags: needinfo?(ludovic) → needinfo?(scabral)
QA Contact: dmoore → lypulong
(Reporter)

Comment 15

4 years ago
i am now connected.  thanks!
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Tim, you probably want to change your password, since it *looks like* the first 15 characters are in that message.

What resolved this issue, in case we run into it again?
Flags: needinfo?(scabral)
(Reporter)

Comment 17

4 years ago
Thanks, Sheeri.  

The fix was :jtanumijaya adjusting something on the Tableau server.
Thanx!
You need to log in before you can comment on or make changes to this bug.