Closed Bug 1113637 Opened 6 years ago Closed 6 years ago

Blank display for some WebGL games (Could not initialise shader error)

Categories

(Core :: Canvas: WebGL, defect)

35 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox34 --- unaffected
firefox35 - affected
firefox36 - affected
firefox37 - affected

People

(Reporter: FlorinMezei, Unassigned)

References

Details

(Keywords: regression)

Reproducible with: 
- Firefox 35 Beta 5 - BuildID: 20141218174327
- Firefox 36 Aurora latest - BuildID: 20141217004003
- Firefox 37 Nightly latest - BuildID: 20141218030202
NOT Reproducible with:
- Firefox 34.0.5

Reproducible on: Windows 7 x64, Windows 8.1 x86 (AMD and NVidia cards)
Works on: Mac OS X 10.7.5, Ubuntu 14.04 x86

Steps to reproduce:
1. Open Firefox and load the following WebGL games: http://oos.moxiecode.com/js_webgl/monster_truck/, http://racer.nomo.hu/.

Expected results:
The games load, and can be played.

Actual results:
The games load but cannot be played as display is blank. Error "Could not initialise shader" displays in the console.
See full console logs at: http://pastebin.com/FKw3ZZtr, http://pastebin.com/Ji72B2gq.

The issue reproduces the same way on IE and Chrome, but at the same time is a regression from 2014-10-10:
Regression window(m-c)
Good: 2014-10-09 (BuildID=20141009030201)
Bad: 2014-10-10 (BuildID=20141010030201)
Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5d6ec4dddf14&tochange=50b689feab5f

The main suspect seems to be https://bugzilla.mozilla.org/show_bug.cgi?id=1076020.

This may be the same issue as bug 1113633 (but this bug only reproduces on Windows).
See Also: → 1113633
Milan, can we get someone to look into this?
Flags: needinfo?(milan)
Jeff, game side error, and we're just tougher on them?
Flags: needinfo?(milan) → needinfo?(jgilbert)
Same as bug 1113633, we might want to make a note of this (if it is on our side) since there's nothing ready to land on Beta 35 and we're very late in the cycle.
Without actually dumping the shader sources, this looks like it was broken by us correcting our implementation: The precision of uniforms must match in all shaders at link time.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(jgilbert)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.