[ZTE Open C] Internal Storage is unavailable

RESOLVED DUPLICATE of bug 1105200

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 1105200
3 years ago
3 years ago

People

(Reporter: lenaing, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141125180439

Steps to reproduce:

Tried to download a file from a website to internal storage.
Tried to access internal storage from USB as Mass Storage or MTP.


Actual results:

File does not get downloaded, because "There is no more room on your SD card to save your download.".
Internal storage does not show up as USB Mass Storage or MTP.

In Media Storage -> Internal Storage :
Everything reported as 0B.
Application Storage : 962.60Mb Available

Reported total space for Apps : 987.45 MB.
Used : 24.86 MB
Left : 962.60 MB

Once plugged in, with USB Storage Enabled :

As Mass Storage :
Disk 1 Removable Media F:   (KO, Internal Storage, reported as "No media")
Disk 2 Removable Media G:   (OK, External Storage, reported as FAT32 Filesystem)

As MTP :
sdcard : KO (0 B capacity)
extsdcard : OK


Expected results:

File gets downloaded, because there is space on internal storage ! 
Internal storage shows up as USB Mass Storage or MTP and is usable.

I can install apps, okay it's not the same location, but it means that internal storage works. So why is it a no-no for other media / access methods ?

Additional Info, built from master :
Model : qcom
Software : Boot2Gecko 2.2.0.0-prerelease
Build Number : eng..20140806.064432
Build Identifier : 20141218215855
Git Commit Info : 2014-12-18 20:01:18, 2650bae5

Comment 1

3 years ago
Same problem with Build ID 20141219153315

The device is mounted but proably at the wrong place.

mount:
/dev/fuse /mnt/shell/emulated fuse rw,nosuid,nodev,relatime,user_id=1023,group_id=1023,default_permissions,allow_other 0 0

df:
/mnt/shell/emulated   1006.4M    26.9M   979.5M   4096

but in init.qcom.rc is this line:
mount none /mnt/shell/emulated/0 /storage/emulated/legacy bind

/storage/sdcard0 and /mnt/sdcard are links to /storage/emulated/leagcy

Comment 2

3 years ago
Same problem here, internal sd does not seem to be mounted. I can manually mount it using adb shell:

aroot@ZTE_P821A10:/ # vdc volume list
110 0 sdcard /storage/sdcard 1
110 0 extsdcard /storage/sdcard1 4
200 0 Volumes listed.

root@ZTE_P821A10:/ # vdc volume mount /storage/sdcard                          
605 Volume sdcard /storage/sdcard state changed from 1 (Idle-Unmounted) to 3 (Checking)
605 Volume sdcard /storage/sdcard state changed from 3 (Checking) to 4 (Mounted)
200 0 volume operation succeeded

File /system/etc/vold.fstab contains:
dev_mount sdcard /storage/sdcard1 auto /devices/msm_sdcc.2/mmc_host

File /system/etc/volume.cfg contains (no line-break at EOF):
create sdcard /storage/sdcard

Comment 3

3 years ago
Seems a duplicate of bug 1105200
(Reporter)

Comment 4

3 years ago
I confirm that renaming /etc/volume.cfg to /etc/volume.cfg.sav works.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1105200
You need to log in before you can comment on or make changes to this bug.