[ZTE Open C] Start using geolocation reboot device

RESOLVED WORKSFORME

Status

Firefox OS
General
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: lenaing, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141125180439

Steps to reproduce:

Enabled Geolocation in Settings,
Installed some apps (Nokia Here Maps, zMaps, Remember GPS...)
Let them use the geolocation API when prompted


Actual results:

Once permission shared with the apps, and geolocation icon added to the top bar, device reboots to furry-foxy-firefox.
Device is okay, until you start to use an app working with the geolocation API.


Expected results:

No reboot, but a working geolocation app.
(Reporter)

Comment 1

3 years ago
(In reply to lenaing from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; rv:34.0) Gecko/20100101 Firefox/34.0
> Build ID: 20141125180439
> 
> Steps to reproduce:
> 
> Enabled Geolocation in Settings,
> Installed some apps (Nokia Here Maps, zMaps, Remember GPS...)
> Let them use the geolocation API when prompted
> 
> 
> Actual results:
> 
> Once permission shared with the apps, and geolocation icon added to the top
> bar, device reboots to furry-foxy-firefox.
> Device is okay, until you start to use an app working with the geolocation
> API.
> 
> 
> Expected results:
> 
> No reboot, but a working geolocation app.

Woops, forgot build info, here you go :

Additional Info, built from master :
Model : qcom
Software : Boot2Gecko 2.2.0.0-prerelease
Build Number : eng..20140806.064432
Build Identifier : 20141218215855
Git Commit Info : 2014-12-18 20:01:18, 2650bae5
(In reply to lenaing from comment #0)
> Once permission shared with the apps, and geolocation icon added to the top
> bar, device reboots to furry-foxy-firefox.
> Device is okay, until you start to use an app working with the geolocation
> API.

To access GPS hardware we need to talk to a binary driver IIRC. There are good chances that the driver shipping with the Open C has an interface that is not compatible with the current gecko master branch.
(Reporter)

Comment 3

3 years ago
(In reply to Gabriele Svelto [:gsvelto] from comment #2)
> To access GPS hardware we need to talk to a binary driver IIRC. There are
> good chances that the driver shipping with the Open C has an interface that
> is not compatible with the current gecko master branch.

Okay, used to work with my last build in late October.
I will wait for the update :)
Might be the same issue as on bug 1056242
(Reporter)

Comment 5

3 years ago
Works for me with this device ZTE Open C (French, Leclerc) with the two following versions :

Model : qcom
Software : Boot2Gecko 2.1.0.0-prerelease
Plateform : 34.0
Build ID : 20150228210343
Git commit info : 2015-02-25 18:20:09 - 5d3479fd

Model : qcom
Software : Boot2Gecko 2.2.0.0-prerelease
Build Number : eng..20140806.064432
Plateform : 37.0
Build ID : 20150412180546
Git commit info : 2015-04-10 21:41:12 - cec00d64
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.