Test failure "Plain-theme is marked to be enabled. - 'upgrade' should equal 'enable'" in testChangeTheme.js

RESOLVED FIXED

Status

Mozilla QA
Mozmill Tests
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: mihaelav, Assigned: cosmin)

Tracking

({regression})

unspecified
x86
All
regression

Firefox Tracking Flags

(firefox37 fixed)

Details

(Whiteboard: [mozmill-test-failure][mozmill-test-skipped], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Module:    testInstallTheme
Test:      testChangeTheme.js
Failure:   Plain-theme is marked to be enabled. - 'upgrade' should equal 'enable'
Branches:  37a1.0
Platforms: All

Reports:
http://mozmill-daily.blargon7.com/#/functional/failure?app=Firefox&branch=All&platform=All&from=2014-12-12&to=2014-12-19&test=%2FtestAddons%2FtestChangeTheme.js&func=testInstallTheme
(Reporter)

Updated

3 years ago
status-firefox37: --- → affected
(Assignee)

Comment 1

3 years ago
This fails all the time, it should have been disabled! 
http://mozmill-daily.blargon7.com/#/functional/failure?app=Firefox&branch=All&platform=All&from=2014-12-12&to=&test=%2FtestAddons%2FtestChangeTheme.js&func=testInstallTheme
(Assignee)

Comment 2

3 years ago
Created attachment 8539994 [details] [diff] [review]
skip-patch

Henrik can you please review this skip-patch?
Attachment #8539994 - Flags: review?(hskupin)
(Assignee)

Updated

3 years ago
Keywords: regression, regressionwindow-wanted
Comment on attachment 8539994 [details] [diff] [review]
skip-patch

Review of attachment 8539994 [details] [diff] [review]:
-----------------------------------------------------------------

This is a regression, so please get this one investigated ASAP. Something seems to be wrong with the theme versioning?
Attachment #8539994 - Flags: review?(hskupin) → review+
Comment on attachment 8539994 [details] [diff] [review]
skip-patch

Review of attachment 8539994 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry, but this patch cannot be applied.
Attachment #8539994 - Flags: review+ → review-
Comment on attachment 8539994 [details] [diff] [review]
skip-patch

Review of attachment 8539994 [details] [diff] [review]:
-----------------------------------------------------------------

It applied well to me, tested, landed:
http://hg.mozilla.org/qa/mozmill-tests/rev/0432a77a4c31 (default)

Something is strange as we have multiple tests with similar issues:
bug 1112517 - Test failure 'Service is no longer marked for uninstall - 'uninstall' should equal ''
bug 1108948 - Test failure 'Addon is no longer marked for uninstall' 
We have to investigate this.
Attachment #8539994 - Flags: review- → review+
status-firefox37: affected → disabled
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure][mozmill-test-skipped]
(Assignee)

Comment 6

3 years ago
This is strange, all Jenkins jobs failed since Friday on production/staging I couldn't reproduce it locally or on production. The extension didn't changed so I don't think it might be a change in addon version, I expect to be a change either in library or in Firefox itself.
I see it fails at an assert.equal, maybe it's a race condition and we need to waitFor there:
http://hg.mozilla.org/qa/mozmill-tests/file/default/firefox/tests/functional/testAddons/testChangeTheme.js#l99
(Assignee)

Comment 8

3 years ago
I checked with a build from weekend, it still passes for me so the remaining thing I can think of it might be the machine loading so a waitFor would be a good try.
(Assignee)

Comment 9

3 years ago
Created attachment 8540123 [details] [diff] [review]
patch v1.0

Andreea can you check this?
Attachment #8540123 - Flags: review?(andreea.matei)
(In reply to Cosmin Malutan from comment #8)
> I checked with a build from weekend, it still passes for me so the remaining
> thing I can think of it might be the machine loading so a waitFor would be a
> good try.

Where did you check that? On one of the machines in SCL3? It was failing all the time as you stated, so I don't see why you cannot reproduce it anymore now.
(Assignee)

Comment 11

3 years ago
I failed on production on all nodes, you might check mozilla-central_functional jobs on Jenkins, as I stated all jobs failed. I couldn't reproduce the failure on neither locally or on production. I ran the test itself at least 20 times on production and locally with latest Nightly, also complete testruns.
I keep testing it.
(Assignee)

Comment 12

3 years ago
Oh my, I think I did something wrong firs time I ran a complete testrun. It fails all the times when I ran complete testruns. The theme is already installed when we ran the test.
The reason is that with the re-factoring from bug 1108993, we don't uninstall the theme installed in the first restart test, which bu the way is duplicated and should be fully removed. 
The re-factored test was previously removing the Theme installed in 
> https://github.com/mozilla/qa-mozmill-tests/blob/master/firefox/tests/functional/restartTests/testAddons_installTheme/manifest.ini
Now the re-factored test runs after the change theme test.
All that we have to do is to fully remove the restartTests/testAddons_installTheme as is duplicated in testInstallUninstallTheme
Comment on attachment 8540123 [details] [diff] [review]
patch v1.0

Review of attachment 8540123 [details] [diff] [review]:
-----------------------------------------------------------------

Meanwhile Cosmin reproduced this after multiple testruns, he's working on the real cause and fix.
Attachment #8540123 - Flags: review?(andreea.matei)
(Assignee)

Comment 14

3 years ago
It will be fixed with bug 1110639
Depends on: 1110639
We fixed that on nightly, will continue with the other branches there but here it was the only one affected. Cosmin, please recheck now to be sure I can backout the skip. Thanks!
(Assignee)

Comment 16

3 years ago
Yep, that fixed it, it can be re-enabled on default.
http://mozmill-crowd.blargon7.com/#/functional/report/f4189e259b668417231c4d9ed055fc87
Assignee: nobody → cosmin.malutan
Status: NEW → ASSIGNED
Enabled:
http://hg.mozilla.org/qa/mozmill-tests/rev/266a4b541b43 (default)
Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox37: disabled → fixed
Resolution: --- → FIXED
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.