If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Settings] Modifying WiFi SSID or Password fields will break scrolling throughout the Settings app

RESOLVED DUPLICATE of bug 1112031

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 1112031
3 years ago
3 years ago

People

(Reporter: Marty, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected)

Details

(Whiteboard: [2.2-Daily-Testing])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8539397 [details]
logcat-Settings-Scrolling.txt

Description:
This issue will occur any time the user modifies an SSID or Password field in 'Internet Sharing>Hotspot Settings,' as well any time the user modifies the SSID or Password field in 'WiFi>Manage Networks>Join Hidden Network'

This issue has also been seen intermittently after inputting a password into a publicly discoverable WiFi network.

Notes:
-Scrolling will only break in the Settings app, not in other apps.
-This issue is temporarily resolved if the user force closes the Settings app in Card View and relaunches.

-It is possible this issue is related to the fix for bug 1113099

Repro Steps:
1) Update a Flame device to BuildID: 20141219040202
2) Open the Settings app and navigate to Internet Sharing
3) Open Hotspot Settings
4) Change the SSID Network Name
5) Return to the main settings menu, and attempt to scroll up and down.

Actual:
Scrolling is non-functional across the Settings app.

Expected: 
Scrolling is always functional.

Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141219040202
Gaia: deb90229734e5397cda806fb11f2e001fba83399
Gecko: 021b09e92d30
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 5/5
See attached: logcat
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QAWanted for branch checks.

Nominating to block, this is a functional regression that makes the app barely usable (can't scroll) until closing.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
Actually this is a duplicate of bug 1112031
Status: NEW → RESOLVED
blocking-b2g: 2.2? → ---
Last Resolved: 3 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 1112031
You need to log in before you can comment on or make changes to this bug.