Crash/Hang running youtube's MSE tests

RESOLVED DUPLICATE of bug 1114383

Status

()

P2
normal
RESOLVED DUPLICATE of bug 1114383
4 years ago
4 years ago

People

(Reporter: cmtalbert, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Windows 8.1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
= STR =
Open a tab to http://yt-dash-mse-test.commondatastorage.googleapis.com/
Click "Run All"

Expected
Test runs to completion with errors

Actual 
Test damages entire browser session and does not run to completion (might be intermittent)

So, I hit two strange behaviors one with E10s mode on and one with E10s mode off. Both were from clicking on the "run all" link on the page and both happened somewhere between the Buf/Unbuf test (number 40 something-ish) and the Frame Gaps test.

= E10S Enabled =
I crashed the content process. Here is the report: https://crash-stats.mozilla.com/report/index/f76c50ca-3cc9-442f-ba01-e0c302141219

= E10s Disabled =
It hung the entire browser. It seemed like it hung a rendering thread because I could do some things - like switch between windows, click the "new tab" button, but I couldn't type in the search or URL bar, I couldn't see the new tabs I created from clicking the button, but if I tried to drag the space where they would be, a thumbnail would appear showing the new tab page. And, when I restored after killing the task, it restored with several new tab pages there.

Further attempts to repro this saw the bug become intermittent, and then trying to load the page results in an error: "XML has no style data". So I don't know if this is a case of google updating the page while I was running it or the page damaging itself while running. I tried loading in different browsers and am now constantly getting the XML error, so I think there has been a server update during my testing this morning.

Sorry for the crappy report, wish I could pinpoint what is happening here.

I'm running today's nightly (2014-12-19)
Here is my graphics information for this machine:
Graphics
--------

Adapter Description: Intel(R) HD Graphics Family
Adapter Drivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
Adapter RAM: Unknown
Device ID: 0x0a16
Direct2D Enabled: true
DirectWrite Enabled: true (6.3.9600.17111)
Driver Date: 8-5-2014
Driver Version: 10.18.10.3907
GPU #2 Active: false
GPU Accelerated Windows: 3/3 Direct3D 11 (OMTC)
Subsys ID: 221417aa
Vendor ID: 0x8086
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Priority: -- → P2
http://yt-dash-mse-test.commondatastorage.googleapis.com/ is XML content for me.
Where is your "Run All" link ?

Could you please confirm which URL you used ? thank you
Flags: needinfo?(ctalbert)
This looks like memory corruption caused by bug 1114383. Please reopen if you hit this again.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ctalbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 1114383
You need to log in before you can comment on or make changes to this bug.