Closed Bug 1113786 Opened 5 years ago Closed 5 years ago

'Find in page' search toolbar doesn't respect privacy in private tabs/mode, keeps search term after closing private tab

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 37
Tracking Status
fennec + ---

People

(Reporter: aryx, Assigned: capella)

Details

Attachments

(1 file, 1 obsolete file)

Firefox for Android Nightly build today with the patch from bug 1112230 on Try: https://tbpl.mozilla.org/?tree=Try&rev=d320d70c5fca
Android 4.1.2 stock on Nexus S

The 'Find in page' search toolbar doesn't respect the privacy but keeps the search term used on a private tab after closing it.

Steps to reproduce:
1. Launch Firefox for Android.
2. Open a new private tab, e.g. a news site.
3. Search for a common word, e.g. "the".
4. Open the tab list and close the private tab by swiping.
5. Load a page in the normal tab and open again the 'Find in page' toolbar.

Actual result:
Search term from 3. shown

Expected result:
Search bar empty
tracking-fennec: --- → ?
Assignee: nobody → markcapella
tracking-fennec: ? → +
Attached patch bug1113786.diff (obsolete) — Splinter Review
Persisting the string across page searches is convenient, and I'm pretty sure we don't want to simply clear the field each time we open the FIPB.

Probably the best solution we might offer is to clear it on FIPB close, if the user initiated or otherwise searched while in a private tab.
Attachment #8546449 - Flags: review?(wjohnston)
Status: NEW → ASSIGNED
How strongly would people care if we cleared the Find text box on every "close"? That would be my preference. It might seem a bit conservative, but it handles all edge cases.
Flags: needinfo?(aaron.train)
Flags: needinfo?(aaron.train)
Flags: needinfo?(alam)
It seems to me like the "Find in page" bar should close when the user closes/moves away from that tab. Particularly because one cannot trigger "Find in page" in about:home anyways (what you see when you start a new tab).

Specifically for this bug though... I agree, in private mode, it should definitely clear and close.

Hope that helps!
Flags: needinfo?(alam)
Attached patch bug1113786.diffSplinter Review
Simple is better wfm
Attachment #8546449 - Attachment is obsolete: true
Attachment #8546449 - Flags: review?(wjohnston)
Attachment #8546926 - Flags: review?(mark.finkle)
Comment on attachment 8546926 [details] [diff] [review]
bug1113786.diff

LGTM. I'll file a bug about closing the FindInPageBar when switching tabs.
Attachment #8546926 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/d606591cf149
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
You need to log in before you can comment on or make changes to this bug.