Closed Bug 1113791 Opened 5 years ago Closed 5 years ago

browser.bookmarks.autoExportHTML does not work

Categories

(SeaMonkey :: Bookmarks & History, defect)

x86
Linux
defect
Not set

Tracking

(seamonkey2.30 wontfix, seamonkey2.31 wontfix, seamonkey2.32+ fixed, seamonkey2.33+ fixed, seamonkey2.34+ fixed)

RESOLVED FIXED
seamonkey2.34
Tracking Status
seamonkey2.30 --- wontfix
seamonkey2.31 --- wontfix
seamonkey2.32 + fixed
seamonkey2.33 + fixed
seamonkey2.34 + fixed

People

(Reporter: wjaguar, Assigned: wjaguar)

Details

Attachments

(1 file)

Fully equivalent to Firefox bug #919506:
https://bugzilla.mozilla.org/show_bug.cgi?id=919506
Same symptoms as in there, and same cause - albeit located in a different file: suite/common/src/nsSuiteGlue.js
Encountered in Seamonkey 2.31, but the same buggy line is present in trunk too, as of today.

Solution is exactly the same as the fix for #919506; patch against today's trunk is attached.
> browser.bookmarks.autoExportHTML does not work

Confirmed.

> Patch

Can that be applied directly to:
> omni.ja: \components\nsSuiteGlue.js

Cause when I did so, assuming I did it correctly, I was getting a /directory/ named bookmarks.html rather then a /file/ (containing the exported bookmarks).

(Or does something also need to happen with omni.ja: \jsloader\resource\gre\components\nsSuiteGlue.js ?)
Status: UNCONFIRMED → NEW
Ever confirmed: true
> I was getting an [empty] /directory/ named bookmarks.html rather then a /file/
> (containing the exported bookmarks)

That is a part of the bug itself, it seems, (affecting SeaMonkey > 2.22.1) & is not fixed by the patch.
If a bookmarks.html (file) already exists, it looks like it is retained, & updated.
But if it does not already exist, an (empty) directory (named bookmarks.html) is created instead.

(I'm not a programmer, but I don't believe the patch is accomplishing anything?)
> Or does something also need to happen with omni.ja: \jsloader\resource\gre\components\nsSuiteGlue.js

This is pre-compiled form of same file. It need be deleted, for the changes to components/nsSuiteGlue.js to have any effect.

>is not fixed by the patch.

And this is exactly what it looks like if jsloader/resource/gre/components/nsSuiteGlue.js is left untouched, *and/or* precompiled code cache isn't purged.
Here the proper technique of patching omni.ja is explained in detail:
http://inpursuitoflaziness.blogspot.com/2014/01/editing-files-from-omnija-in-firefox-20.html
By George, or Dmitry, you've got it!

It works :-).

And thanks.
Assignee: nobody → wjaguar
Status: NEW → ASSIGNED
Comment on attachment 8539471 [details] [diff] [review]
Patch for suite/common/src/nsSuiteGlue.js

Thank you very much for the patch Dmitry!
Attachment #8539471 - Flags: review+
Comment on attachment 8539471 [details] [diff] [review]
Patch for suite/common/src/nsSuiteGlue.js

[Approval Request Comment]
Regression caused by (bug #): Bug 910885
User impact if declined: browser.bookmarks.autoExportHTML did not work anymore
Testing completed (on m-c, etc.): Port patch from Firefox which has been fixed for more than a year.
Risk to taking this patch (and alternatives if risky): no risk, bustage fix.
String changes made by this patch: None
Attachment #8539471 - Flags: approval-comm-beta?
Attachment #8539471 - Flags: approval-comm-aurora?
Pushed to comm-central
http://hg.mozilla.org/comm-central/rev/5b7a5c36aeec

Thank you Dmitry Groshev!
Keywords: checkin-needed
Target Milestone: --- → seamonkey2.34
Attachment #8539471 - Flags: approval-comm-beta?
Attachment #8539471 - Flags: approval-comm-beta+
Attachment #8539471 - Flags: approval-comm-aurora?
Attachment #8539471 - Flags: approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.