maintenance service installed when de-selected during install

RESOLVED INVALID

Status

()

Firefox
Installer
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: fbrfa8.g, Unassigned)

Tracking

({qawanted})

34 Branch
x86_64
Windows 7
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

Updated firefox from an older version without maintenance service.  Chose custom installation.


Actual results:

service was installed without permission


Expected results:

Should be allowed to disable the service installation as in older versions

Comment 1

3 years ago
(In reply to co463 from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101
> Firefox/34.0
> Build ID: 20141126041045
> 
> Steps to reproduce:
> 
> Updated firefox from an older version without maintenance service.  Chose
> custom installation.

Did you use the stub installer or the full installer?


Rob, was there a conscious decision to change something here? (I looked but couldn't find a bug that indicated this)
Component: Untriaged → Installer
Flags: needinfo?(robert.strong.bugs)
Definitely not.

Let's see if someone can reproduce / confirm.
Flags: needinfo?(robert.strong.bugs)
Keywords: qawanted
(Reporter)

Comment 3

3 years ago
Full installer was used.
Summary: maintenance service installed without permission → maintenance service installed when de-selected during install
I was unable to reproduce with the Firefox 34.0.5 candidate and the Firefox 35 release candidate on both WinXP and Win7.

You have to click custom and de-select the installation of the maintenance service. Reporter, did you do this? Can you uninstall the maintenance service and try to reproduce? Thanks!
(Reporter)

Comment 5

3 years ago
It appears I was mistaken.  The computer was running a very old version of firefox, but it was new enough to already have the service installed already.  I guess this can be closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.