[Contact] an event set on the device to a google calendar with no alarm set gets a 30 minute alarm once synced

RESOLVED DUPLICATE of bug 925580

Status

Firefox OS
Gaia::Calendar
RESOLVED DUPLICATE of bug 925580
3 years ago
3 years ago

People

(Reporter: RobertM, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-exploratory-2], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8539592 [details]
Flame2.2logcat.txt

Description:
When creating an event on the phone for a google calendar, if the user sets no alarm, then syncs the device, a 30 minute reminder alarm will be added to the event.

Prereq:
Have the device linked to a google calendar

Repro Steps:
1) Update a Flame to 20141219040202
2) Open Calendar app
3) Create a new event with no alarm set for the google calendar
4) sync the device


Actual:
The event will now have a 30 minute reminder alarm


Expected:
The event still has no alarm


Environmental Variables:
Device: Flame 2.2(319mb)(KitKat)(Full Flash)
Build ID: 20141219040202
Gaia: deb90229734e5397cda806fb11f2e001fba83399
Gecko: 021b09e92d30
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0



Repro frequency: 100%
See attached: logcat, video - http://youtu.be/1OiqCaSuqQs
(Reporter)

Comment 1

3 years ago
This issue also happens on the Flame 2.0 and Flame 2.1

When a google calendar event is set on the device with no alarm and is then synced, a 30 minute alarm will be set on the event automatically.


Flame 2.0

Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141219000200
Gaia: ce83ea7b8e3fa2d1c3fd771fc22b654c18b3c381
Gecko: f57067657bfa
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Flame 2.1

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141219001200
Gaia: 6af3d029bae3a14f400fec0926f0f8ad7b579b4b
Gecko: d41f6bd64343
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
this happens because Google Calendar uses the default alarms when you create an event thru CalDAV, which is really annoying.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 925580
Flags: needinfo?(dharris)
You need to log in before you can comment on or make changes to this bug.