Closed Bug 1113961 Opened 5 years ago Closed 5 years ago

Allow user to enter username & password for http authentication

Categories

(Firefox for iOS :: Browser, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1146464

People

(Reporter: chuongmozilla, Unassigned)

References

Details

Attachments

(1 file)

Attached image challenge.png
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/600.2.5 (KHTML, like Gecko) Version/8.0.2 Safari/600.2.5

Steps to reproduce:

As a user I would like to be able to respond to http authentication requests. For example, when I try to access my router settings.


Actual results:

webView:didReceiveAuthenticationChallenge:completionHandler:
is not implemented thus we reject the challenge.



Expected results:

Allow user to respond with the appropriate username and password. If password is incorrect, provide the challenge again. Also allow the user to reject the challenge.

Example of how Safari handles the request.
Duplicate of this bug: 1122627
Duplicate of this bug: 1122627
It would be ideal if this were tab-modal rather than app-modal, too. Allowing other tabs to be used in the interim would potentially be very useful.
We made bug 1146464 the tracking bug for this feature.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1146464
You need to log in before you can comment on or make changes to this bug.