Closed Bug 1114049 Opened 10 years ago Closed 9 years ago

Poor contrast in private browsing mode address bar text on Sony Xperia Z3

Categories

(Firefox for Android Graveyard :: Theme and Visual Design, defect)

35 Branch
ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: rolyc5, Unassigned)

References

Details

Attachments

(4 files)

Sony's stock ROM on the Xperia Z3 has an iOS-like magnifier when selecting text or moving the cursor around.  In regular tabs, the contents of the address bar look fine within this magnifier, since it is dark text on light background. 

The purpose of this bug report is to bring attention to the poor contrast in the address bar that arises from the dark theme of the Private tabs.  The light text on light background is difficult to read, and the cursor's practically invisible.  Attached is a screenshot of such.

It seems that the magnifier works differently than a mere zoom-in of what is already on screen.  This may be something to take up with Sony rather than a proper Firefox bug.

Device: T-Mobile Sony Xperia Z3 (Model D6616) running Android 4.4.4, Sony Build 23.0.D.1.123
Status: UNCONFIRMED → NEW
Component: Text Selection → Theme and Visual Design
Ever confirmed: true
Summary: Poor contrast in address bar text on Sony Xperia Z3 → Poor contrast in private browsing mode address bar text on Sony Xperia Z3
The updated private browsing colors in bug 864958 [1], assuming we move forward with the original design, change the background to black on white, like regular browsing mode.

Soft dep & possible dupe: bug 864958.

[1]: https://bug864958.bugzilla.mozilla.org/attachment.cgi?id=8434338
Depends on: 864958
The private browsing colors have been updated in our Nightly builds - is this still an issue?
Flags: needinfo?(rolyc5)
This screenshot is of Nightly 42a1.  As you can see from the magnifier, there is no difference between the two private-browsing themes.  Since my last post, I've updated the device to Android 5.0.2 via official over-the-air update.
Flags: needinfo?(rolyc5)
It looks like they keep the background of the magnifier the same and use the text color - I'm not sure what the fix would be here besides changing the text color to something darker. That seems strange through - perhaps there is some threshold after which the change the background color to something darker (for lighter text)?
re comment 6: since, afaict, we can only change the text color and that's not an option, I'm going to WONTFIX this.
Blocks: fennec-pb-v2
No longer blocks: fennec-pb-v1
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: