browser stops accepting keystokes

VERIFIED DUPLICATE of bug 82534

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 82534
16 years ago
13 years ago

People

(Reporter: Simon Falvey, Assigned: saari (gone))

Tracking

Trunk
mozilla1.0
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
After a period of use no text can be entered into text forms or even the URL
bar. Browser also stops accepting Page Up Page Down to scroll

I have found the only work around is to select File->Close and open a new
browser window from say the Mail window. If multiple browser windows are open
can only effect a single window however will effect all tabs on a single window
if multiple tabs are open.

Not seen under 0.9.5 but happening frequestly since upgrade to 0.9.6 2001112012
RH7 RPMS.

Comment 1

16 years ago
confirming on Linux with build 2001112111 but no testcase yet, it just happens
sometimes. Didn't look for a dup.

Comment 2

16 years ago
Possibly a focus issue, and thereby possibly loosely related to Bug 76854 ? Wild
guesses only...
(Reporter)

Comment 3

16 years ago
If it is related to Bug 76854 for info I have gtk+-1.2.10-11 installed. Also I
am having the problem under Gnome/sawfish as opposed to running without a WM or
using TWM.

I have noticed that the browser _is_ in fact accepting keystrokes when this
occurs but its as through a modifier key is being pressed and got stuck. For
instance when I press F up pops the file bookmark dialog?!?. In fact it just
happened while entering this info just as I clicked on bookmarks in personal
toolbar. 

If I focus on another window I can see that in fact it is not that a key is
stuck as the other window (what every app it might be including Moz Mail)
accepts input without problem.

Comment 4

16 years ago
not form submission
->
Assignee: alexsavulov → mpt
Component: Form Submission → User Interface Design
QA Contact: vladimire → zach

Comment 5

16 years ago
This bugs the hell out of me.  Currently using 2001112011 on Mac OS 9; had the
same problem in earlier builds.  All keypresses completely stop responding,
including menu access keys (accel-N to open a new window, for example).  Only
that one window stops responsing to keystrokes; every other window works fine. 
Mouse clicks respond fine.  Switching between windows or switching between apps
doesn't fix the problem, although I could swear it did once.

Comment 6

16 years ago
Just reproduced on OS9.x 2001113008. Can't figure out how I did it, though.
Looks like barely reproducible. I should point out, though, that it first--just
happened again. It looks as if it's a focus problem, but doesn't seem related to
bug 76854, bug 73727, or bug 78928. Those seem to say reproducible always;
however, it may be part of a larger problem.

1. was typing in here
2. switched tabs, and used back button menu to go back one page (don't ask why)
3. would not type until I used the mouse to focus the tab pane

Comment 7

16 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

16 years ago
This can't possibly be in the correct component. Over to XP Apps. 
Assignee: mpt → pchen
Component: User Interface Design → XP Apps
QA Contact: zach → sairuh
(Reporter)

Comment 9

16 years ago
Also occurs in 0.9.7 Linux build 2001122617

Comment 10

16 years ago
-> default assignee
Assignee: pchen → trudelle

Comment 11

16 years ago
->bryner, but we'll need a reproducible case.
Assignee: trudelle → bryner

Comment 12

16 years ago
Oh come on, that takes all the fun out of it. ;-)

Triggering bug 114559 (also described in my duplicate bug 116354) usually seems to make the browser window stop accepting keystrokes, although that could be a completely unrelated issue.  Aside from that, I haven't found anything to duplicate this, it just sort of happens.  I haven't encountered it recently.
-> saari, this seems to be happening on mac as well.  Think you could take a look?
Assignee: bryner → saari
OS: Linux → All
(Assignee)

Comment 14

16 years ago
So the test case for this bug is:

1. was typing in here
2. switched tabs, and used back button menu to go back one page (don't ask why)
3. would not type until I used the mouse to focus the tab pane

Correct?
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.9

Comment 15

16 years ago
nope, what this bug (as I understand it) is about is, a field can have focus
(blinking insertion point) but you still can't type.  You can click in the URL
bar, select text, try to type, nothing happens.  Keyboard shortcuts for menu
commands don't work either.

I have not seen this problem recently at all, so I suspect it may actually be
fixed - but then again, it was never really repeatable, so maybe I've just been
lucky.

I mentioned bug 114559 above - that appears to have been fixed as well.

Are we all talking about the same thing here, or are there a few different bugs
with similar symptoms?
(Assignee)

Updated

16 years ago
Keywords: nsbeta1

Comment 16

16 years ago
Please enlighten me, why is this not a dupe of bug 82534?
If they're not the same bug I bet half of the duplicates and comments there
should be on this one.
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 17

16 years ago
Resolving as dupe of bug 82534.

*** This bug has been marked as a duplicate of 82534 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.