Seamonkey v2.32 Beta 2 Build 1 crashes after updating german language-file in addon-manager

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Stefan Gies, Unassigned)

Tracking

({crash})

SeaMonkey 2.32 Branch
x86_64
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0 SeaMonkey/2.32
Build ID: 20141218225525

Steps to reproduce:

Updating Seamonkey v2.32 Beta 1 Build 1 with German language-pack v2.32 Beta 1 to Seamonkey v2.32 Beta 2 Build 1 with German language-pack v2.32 Beta 2


Actual results:

http://crash-stats.mozilla.com/report/index/bp-695384eb-d75c-4cd8-833d-804622141221


Expected results:

Restarting seamonkey and running without crash
(Reporter)

Comment 1

3 years ago
http://crash-stats.mozilla.com/report/index/bp-4a98f374-0c62-494c-9685-1c6da2141222

Comment 2

3 years ago
https://crash-stats.mozilla.com/report/list?signature=js%3A%3Adetail%3A%3AHashTable%3Cjs%3A%3AHashMapEntry%3CJSAddonId*%2C+nsCOMPtr%3CnsIAddonInterposition%3E+%3E%2C+js%3A%3AHashMap%3CJSAddonId*%2C+nsCOMPtr%3CnsIAddonInterposition%3E%2C+js%3A%3APointerHasher%3CJSAddonId*%2C+3ul%3E%2C+js%3A%3ASystemAllocPolicy%3E%3A%3AMapHashPolicy%2C+js%3A%3ASystemAllocPolicy%3E%3A%3Alookup%28JSA...&range_value=28&range_unit=days&date=2014-12-31

> Operating System  Percentage  Number Of Crashes
> Linux                53.85 %                 14
> OS X 10.10           23.08 %                  6
> OS X 10.6            15.38 %                  4
> OS X 10.9             7.69 %                  2
Status: UNCONFIRMED → NEW
Crash Signature: [@ js::detail::HashTable<js::HashMapEntry<JSAddonId*, nsCOMPtr<nsIAddonInterposition> >, js::HashMap<JSAddonId*, nsCOMPtr<nsIAddonInterposition>, js::PointerHasher<JSAddonId*, 3ul>, js::SystemAllocPolicy>::MapHashPolicy, js::SystemAllocPolicy>::loo&hellip;
Ever confirmed: true
Keywords: crash

Updated

3 years ago
Severity: normal → critical

Comment 3

2 years ago
@reporter:
Is the problem still reproducible for you with a current SeaMonkey version?
(Reporter)

Comment 4

2 years ago
The error is not present.

Comment 5

2 years ago
Closing this one due to Comment 4

@Reporter /  @all: Please feel free to reopen this Bug if if the problem reappears with a current SeaMonkey version and a current OS.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.