On the Firefox product page, the download buttons says "English"

RESOLVED FIXED in 2015Q1

Status

P4
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: MikkCZ, Assigned: rrosario)

Tracking

unspecified
2015Q1
All
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=1 u=user c=kb s=2015.3, URL)

Let's open the Firefox product page on SUMO. On the top right you can see the download button, which has a subtitle "English (US)" in original, but is not properly adjusted for other locales, just translated. All languages I tested say the download is in "English".

cs: Anglický
de: Englisch (US)
fr: Anglais (US)
it: Inglese (US)

IMO the language do not have to be specified on the button at all, as the download page decides about the locale to download.
Moving this to "Knowledge Base Software" as the "...Content" component is for articles requests only.

We'll need SUMO Dev's help to make this change.
Component: Knowledge Base Content → Knowledge Base Software
The style guide suggests that the language matters, so we should keep it there. This should be pretty simple to use the language name and code we already know, instead of putting it in the string for localizers to translate.
Whiteboard: p=1 u=user c=kb s=2015.1
bumping to the next sprint.
Whiteboard: p=1 u=user c=kb s=2015.1 → p=1 u=user c=kb s=2015.2

Updated

4 years ago
Priority: -- → P4
Pushing to next sprint.
Whiteboard: p=1 u=user c=kb s=2015.2 → p=1 u=user c=kb s=2015.3
(Assignee)

Updated

4 years ago
Assignee: nobody → rrosario
Target Milestone: --- → 2015Q1
(Assignee)

Comment 6

4 years ago
Deployed to prod:
https://github.com/mozilla/kitsune/commit/25f576f0629cb8bbf5adadca8b3e75e0d8cfbf01
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Duplicate of this bug: 1108518
You need to log in before you can comment on or make changes to this bug.