Closed Bug 1114327 Opened 7 years ago Closed 7 years ago

Opacity transition breaks when transform-style: preserve-3d is set

Categories

(Firefox :: Untriaged, defect)

34 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1098266

People

(Reporter: alexander, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

Set up an element with both "transition: opacity .." and "transform-style: preserve-3d". Toggle class 'min' with less opacity by click.


Actual results:

Element disappears when clicked then appears back with needed opacity. When clicked again still no transition.


Expected results:

Element should have changed its opacity smoothly from one to another value.

Here is the fiddle: http://jsfiddle.net/cx9akk26/
FF 31.0 — All is ok, no bug
FF 34.0.5 — Bug is reproducing
This was fixed by Bug 1098266
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1098266
You need to log in before you can comment on or make changes to this bug.