bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Firefox does not render Indian Rupee UTF8 character

UNCONFIRMED
Unassigned

Status

()

Core
Layout: Text
UNCONFIRMED
4 years ago
4 years ago

People

(Reporter: Sachin, Unassigned)

Tracking

30 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

164 bytes, text/html
Details
(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36

Steps to reproduce:

On my website page I used UTF-8 character for Indian Rupee symbol


Actual results:

Instead of rendering Indian Rupee symbol firefox rendered an rectangle with some numbers in it


Expected results:

Indian Rupee symbol should have been rendered
(Reporter)

Comment 1

4 years ago
I used HTML UTF-8 character code from this link - http://www.fileformat.info/info/unicode/char/20b9/index.htm

Comment 2

4 years ago
Please create a simple HTML test file and attach it here
(use the "Add an attachment" link above)
(Reporter)

Comment 3

4 years ago
Created attachment 8540506 [details]
Test.html

Chrome is showing Rupee symbol for this file on my computer but firefox does not.
(Reporter)

Comment 4

4 years ago
Sorry, attached wrong file. Will attach a valid one
(Reporter)

Comment 5

4 years ago
Created attachment 8540509 [details]
Test.html

HTML file with Indian rupee symbol
Attachment #8540506 - Attachment is obsolete: true

Updated

4 years ago
Component: Untriaged → Layout: Text
Product: Firefox → Core
(In reply to Sachin from comment #3)
> Created attachment 8540506 [details]
> Test.html
> 
> Chrome is showing Rupee symbol for this file on my computer but firefox does
> not.

What font is Chrome using to show the symbol? (You can probably determine this by right-clicking it and choosing Inspect Element in Chrome, then selecting the "Computed" [style] panel, and scrolling to Rendered Fonts at the very bottom.)

It sounds like this is a failure of font fallback. cc'ing jdaggett.

Comment 7

4 years ago
> attachment 8540509 [details]
> Test.html

works on my system (Release and Nightly)

Mozilla/5.0 (Windows NT 5.1; rv:37.0) Gecko/20100101 Firefox/37.0
(Reporter)

Comment 8

4 years ago
From Computed tab of Inspect element from Chrome-

font-family: 'Source Sans Pro', 'Helvetica Neue', Helvetica, Arial, sans-serif;
You need to log in before you can comment on or make changes to this bug.