recursion using string parameters producing incorrect results

VERIFIED FIXED

Status

()

Core
XSLT
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: David Carlisle, Assigned: Keith Visco)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
http://www.dcarlisle.demon.co.uk/moztest/string.xml
appears in mozilla (0.9.4, Build ID 2001091823) as
}{
--
}}{
---
CC

whereas in IE it appears as
AA
--
BB
--
CC

HTML produced by saxon also agrees with IE.
The stylesheet used by the above XML file is
http://www.dcarlisle.demon.co.uk/moztest/stringxsl.xml
and the saxon-produced result HTML is
http://www.dcarlisle.demon.co.uk/moztest/string.html

David

Comment 1

17 years ago
http://www.mozilla.org/releases/mozilla0.9.6
Hrm. what am I supposed to do. This might have been anything back in the days
of 0.9.4. Anyway, it's fixed now. We had problems with string functions, so
I'll just mark this fixed and not invalid. Sounds nicer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 2

17 years ago
Did you change something?
http://www.dcarlisle.demon.co.uk/moztest/string.xml
still appears in mozilla (0.9.6, Build ID 2001101516) on MacOS X as
}{
--
}}{
---
CC

Comment 3

17 years ago
well, yes, stuff changed a bit. But I have no idea how the changes could have
fixed this. I was suspecting string function cleanup, though that happened 
almost a year ago. That you get from not knowing your checkin history and 
milestone dates.
I don't have a build to verify that 0.9.6 is broken, and I have no clue what
the stylesheet is doing.
If you want to know why this works now, please reduce the testcase to a minimum.
this works for me too on a tip build. Very strange that it didn't work in 
0.9.6. David: have you tried a recent nightly?
(Reporter)

Comment 5

17 years ago
> David: have you tried a recent nightly?
to be honest, no, I mainly track mozilla for mathml support, so as it's not in 
the default builds currently I've only be using the milestone builds.
A mathml 0.9.6 isn't on the download page yet although when I asked on the 
mathml-mozilla newsgroup someone said they had a build which would be there in 
a day or so, so I'll test that when it arrives, but I gather fram the comments 
that it probably won't work in 0.9.6 but should in 0.9.7 due next month, is 
that right?

David
I *think* it work in 0.9.6 but it defenetly should work in 0.9.7
(Reporter)

Comment 7

17 years ago
Just to confirm that the bug is fixed in the Windows MathML build
of 0.9.6 made available today (or yesterday?) from
http://www.mozilla.org/releases/

thanks,

David

Comment 8

16 years ago
we didn't verify for a long time.
I really checked, so VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.