Anamorphic H.264 video not handled properly under Mac OS X

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: Pierre-Aurélien Georges, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

35 Branch
x86
Mac OS X
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8539841 [details]
anamorphic H264 bug FFox 35 Mac.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20141125031119

Steps to reproduce:

1. Open Firefox 35 beta on Mac OS X
2. Go to a URL that contains an anamorphic H264 video inside a HTML5 video element.
3. Play the video


Actual results:

The video plays in 4:3 aspect ratio, with a green square filling the gap between the right border of the video content and the right border of the <video> element


Expected results:

The video should have been played back using the correct aspect ratio (16:9), as it is when playing with Firefox under Windows or with Safari or Chrome under Mac OS X.
(Reporter)

Comment 1

4 years ago
Similar to bug # 845436
Keywords: html5

Comment 2

4 years ago
(In reply to Pierre-Aurélien Georges from comment #0)
> 2. Go to a URL that contains an anamorphic H264 video inside a HTML5 video
> element.


Could provide such a video, please.
Component: Untriaged → Video/Audio
Flags: needinfo?(pageorge)
Product: Firefox → Core
Bug 1111328, adds a method to detect the aspect ratio of a video and the real dimensions of the videos (should the container reports incorrect values).. could use that here...

Please provide an actual URL
Depends on: 1111328

Comment 4

4 years ago
Created attachment 8550973 [details]
Mac_Firefox_35_Video_Issue.png

Confirmed case of green square covering right hand side of video when using Firefox 25 on Mac.

Comment 5

4 years ago
We need a video link to test!
Flags: needinfo?(andrew)
Problem is confirmed also from our side. 
Test-URL will be provided: http://www.keepinmind.info/example.mp4
Thanks for a fix!

Comment 7

4 years ago
Thanks for the video. Did it use to work in the past with previous versions of FF on OSX?
Is it specific to OSX versions?

If it worked previously, can someone install mozregression to find a regression range (see http://mozilla.github.io/mozregression/ for details, no need to bisect, just stop when you get the pushlog).
It worked in FF till FF 35.0 version (through Quicktime).

Config tests FF 35.0: 
MacOS 10.10.1 - confirmed NOT to work.
MacOS 10.9.5 - confirmed NOT to work.
Windows 8.1 - confirmed to work. 

Kind regards
(In reply to KIM Keep In Mind GmbH from comment #6)
> Problem is confirmed also from our side. 
> Test-URL will be provided: http://www.keepinmind.info/example.mp4
> Thanks for a fix!

Is the problem having a green square, or is the problem related to the display ratio not being correct?
Flags: needinfo?(info)
Green square (MacOS 10.9) or colored pixels (MacOS 10.10) ... 
Example image: http://www.keepinmind.info/bugzilla.png
Flags: needinfo?(info)

Updated

4 years ago
Keywords: html5 → regression, regressionwindow-wanted
(In reply to KIM Keep In Mind GmbH from comment #10)
> Green square (MacOS 10.9) or colored pixels (MacOS 10.10) ... 
> Example image: http://www.keepinmind.info/bugzilla.png

Please provide type of mac you are using (and year), in particular what graphic cards it has (macbook pro typically have two).
Could you please test with 36 beta ?

Loic, no need for regression-window. 35 introduced h264 decoding, before it was done via external plugins. The problem is likely related to a particular hardware card with the Apple Video Toolbox decoder. They don't seem to behave the same way
Flags: needinfo?(info)
Keywords: regressionwindow-wanted
Sorry for the late reply. 
Mac models tested - all with the same behavior: 
- MacBook Pro 17 (late 2011), AMD Radeon HD 6770M
- iMac 21 (early 2008), ATI Readon 2600 HD Pro
- iMac 27 (mid 2011), AMD Radeon HD 6770M
- iMac 27 (2013), Intel HD Graphics 4600

Tested with Firefox 36b2: no more problems. No green or colored pixels.
Flags: needinfo?(info)
(Reporter)

Comment 13

4 years ago
I confirm that there are no more problems on Firefox 36b2.

(For your information, I just checked that it was already not working in FF 34 beta, first version to support h264 decoding on Mac OS X)

Also for your information, I had same problem (green squares) on an iMac 27 (late 2009), ATI Radeon HD 4670.
Flags: needinfo?(pageorge)
(Reporter)

Comment 14

4 years ago
(In reply to Loic from comment #7)
> Is it specific to OSX versions?
> 
I think it is specific to OSX, but this has to be confirmed (I don't have seen such bug on Windows but I didn't test with the same FF beta version)

Comment 15

4 years ago
It's certainly specific to OSX, it's not reproducible on Windows (surely because the video decoder about H264 is different).

As it's fixed in FF36+, let's close the bug. Feel free to reopen it if it's back in the future.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(andrew)
Resolution: --- → WORKSFORME

Updated

4 years ago
Duplicate of this bug: 1125242

Comment 17

2 years ago
We need to reopen this bug. Anamorphic videos are distorted on Firefox. See more details here - https://bugzilla.mozilla.org/show_bug.cgi?id=1331110 or below. Tested on Firefox 50 for Mac OS X and Windows.


Steps to reproduce:

1.) Play anamorphic video in Firefox. Test asset - http://se.ooyala.com/jmendez/shaka-anamorphic.html


Actual results:

Video is distorted/stretched. This doesn't happen in other browsers like Chrome or Safari.


Expected results:

Video should render without distortion and fit aspect ratio of video.

Comment 18

2 years ago
Created attachment 8826760 [details]
anamorphic-firefox.png

Updated

2 years ago
Blocks: 1331110
You need to log in before you can comment on or make changes to this bug.