Closed Bug 1114493 Opened 6 years ago Closed 6 years ago

[Rocketbar] cannot get an installed app in rocketbar search result but get "Install App" instead

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0M unaffected, b2g-v2.1 verified, b2g-v2.1S fixed, b2g-v2.2 verified)

VERIFIED FIXED
2.2 S3 (9jan)
Tracking Status
b2g-v2.0M --- unaffected
b2g-v2.1 --- verified
b2g-v2.1S --- fixed
b2g-v2.2 --- verified

People

(Reporter: hcheng, Assigned: kgrandon)

References

Details

(Keywords: branch-patch-needed, regression, Whiteboard: [systemsfe])

Attachments

(2 files)

*Description:
I cannot get an installed app from the search result of rocketbar.

*Steps:
1. type "twitter" in rocketbar (with WIFI connected)
2. tap "Install Twitter" icon to enter marketplace, and then install Twitter
3. return to rocketbar, and clean result.
4. type "twitter" in rocketbar

*Expected results:
After step 4, "Twitter" should be shown in result set.

*Actual results:
After step 4, only "Install Twitter" is listed.

*Env:
Gaia-Rev        2650bae535e15eef5f299cc80d4fab460f78ada7
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/1427b365cd39
Build-ID        20141218160209
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880
see also bug 1114490
Flags: needinfo?(kgrandon)
It seems like we're not updating our local cache of apps during install events. I'll look into this.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Flags: needinfo?(kgrandon)
This is a regression, caused by flatfish bug 1054234. Seems like we need a test here.
Blocks: 1054234
Keywords: regression
Whiteboard: [systemsfe]
Comment on attachment 8540289 [details] [review]
[PullReq] KevinGrandon:bug_1114493_search_installed_apps to mozilla-b2g:master

Dale or Sherman, could either of you take a look at this? Thanks!
Attachment #8540289 - Flags: review?(shchen)
Attachment #8540289 - Flags: review?(dale)
Duplicate of this bug: 1114490
I got marketplace suggestion when off-line. It might be the same problem with this defect.

Steps:
1. use rocketbar to search "google" when on-line
2. turn off the network connection, and clean rocketbar results, then back to homescreen
3. use rocketbar to search "google" (offline)

After step 3, I got "Install Google Search" icon which is provided as a marketplace suggestion app and is not expected.
Comment on attachment 8540289 [details] [review]
[PullReq] KevinGrandon:bug_1114493_search_installed_apps to mozilla-b2g:master

Looks good to me, thanks Kevin!
Attachment #8540289 - Flags: review?(shchen) → review+
Duplicate of this bug: 1088983
Comment on attachment 8540289 [details] [review]
[PullReq] KevinGrandon:bug_1114493_search_installed_apps to mozilla-b2g:master

Let's go with Sherman's review for now. Thanks!
Attachment #8540289 - Flags: review?(dale)
In master: https://github.com/mozilla-b2g/gaia/commit/bdedbaf9f18a43c091ede770407d68d38582fe29
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Hi Kevin,

The fix is not included in v2.1. Could you please update it?
Flags: needinfo?(kgrandon)
Comment on attachment 8540289 [details] [review]
[PullReq] KevinGrandon:bug_1114493_search_installed_apps to mozilla-b2g:master

Requesting uplift to v2.1 per comment 12.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature implementation.
[User impact] if declined: Poor experience with search sometimes with installing apps.
[Testing completed]: Manual and unit testing.
[Risk to taking this patch] (and alternatives if risky): Fairly low risk, sandboxed to one part of the code.
[String changes made]: None.
Flags: needinfo?(kgrandon)
Attachment #8540289 - Flags: approval-gaia-v2.1?(bbajaj)
Kevin, can you confirm if this use-case was ever working prior to 2.1 and we regressed it at some point ?
Flags: needinfo?(kgrandon)
(In reply to bhavana bajaj [:bajaj] from comment #14)
> Kevin, can you confirm if this use-case was ever working prior to 2.1 and we
> regressed it at some point ?

Yes, this was working in 2.0, then was regressed in 2.1.
Flags: needinfo?(kgrandon)
Attachment #8540289 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
There's the branch patch, let's see what gaia-try does.
Flags: needinfo?(kgrandon)
===Verified v2.1 with below build===
Build ID               20150115161206
Gaia Revision          230a9c5303e2113f7dbcaf431441ae2138853141
Gaia Date              2015-01-15 21:38:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/e43e97795f5d
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150115.200104
Firmware Date          Thu Jan 15 20:01:13 EST 2015
Bootloader             L1TC000118D0

===Verified v2.2 with below build===
Build ID               20150115162503
Gaia Revision          7c5b27cad370db377b18a742d3f3fdb0070e899f
Gaia Date              2015-01-12 17:32:38
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d9c9b7e379d6
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150115.200646
Firmware Date          Thu Jan 15 20:06:55 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Added a testonly follow-up to fix some Gij errors on 2.1 TH: https://github.com/mozilla-b2g/gaia/commit/5745e44273aeda4861d0bf369fc47851c69a040b
You need to log in before you can comment on or make changes to this bug.