[Flame][Calendar]Device will display duplicated options while creating new event.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: liuke, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame][v2.1][Calendar]Device will display duplicated options while selecting accounts to save the newly-created event.
Found time:11:02
See attachment:1102.mp4 and logcat_1102.txt

[2.Testing Steps]: 
1.Launch Calendar.
2.Tap the Menu icon -> "Settings", add a Gmail account.
3.Go back to Day page, Tap "+" to create new event.
4.Tap the "Offline calendar" to select account for saving this event to. 

S/N:25622

[3.Expected Result]: 
4.Every event should be saved to only one account.

[4.Actual Result]: 
4.Every option will be displayed for twice.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        6af3d029bae3a14f400fec0926f0f8ad7b579b4b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-2g34_v2_1/rev/39eaa987093b
Build-ID        20141221001202
Version         34.0

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID: Free  Test
(Reporter)

Updated

4 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → unaffected
(Reporter)

Comment 1

4 years ago
Created attachment 8540078 [details]
1102.MP4
(Reporter)

Comment 2

4 years ago
Created attachment 8540079 [details]
logcat_1102.txt
(Reporter)

Comment 3

4 years ago
The problem is verified not happen on latest Flame 2.1 build. If anyone can reproduce it, please reopen again.

Steps:
1.Launch Calendar.
2.Tap the Menu icon -> "Settings", add a Gmail account.
3.Go back to Day page, Tap "+" to create new event.
4.Tap the "Offline calendar" to select account for saving this event to. 

Actual Result: 
4.Every event is saved to only one account.

Fail rate:0/15

Flame 2.1 version:
Gaia-Rev        77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/452a023ae7b2
Build-ID        20150119001222
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150119.035259
FW-Date         Mon Jan 19 03:53:10 EST 2015
Bootloader      L1TC000118D0
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.