Textarea scrollbars are rendered natively

RESOLVED INVALID

Status

()

RESOLVED INVALID
17 years ago
17 years ago

People

(Reporter: christopher_brien, Assigned: mikepinkerton)

Tracking

({platform-parity})

Trunk
PowerPC
Mac OS X
platform-parity
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.5+)
Gecko/20011116
BuildID:    2001111609

The scrollbars in textareas are rendered by Aqua, instead of xul, hence they
have the gumdrop look and feel and aren't skinnable. They should be rendered by
Mozilla.

Reproducible: Always
(Reporter)

Comment 1

17 years ago
Sorry, wrong component
Component: HTMLFrames → HTML Form Controls

Comment 2

17 years ago
dup of bug 47052 or 58317?
(Reporter)

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 58317 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

17 years ago
Actually, no. Windows uses xul scrollbars for textareas, but not on Mac OS X. By
rights this should be a dupe of bug 58317, but for some reason this specific
issue is OS X specific. I'm not sure if I should reopen this. Someone shout me
down if I shouldn't :o)

Comment 5

17 years ago
oops.. xul used in textarea scrollbars on Linux too. Reopening.

Status: RESOLVED → UNCONFIRMED
Keywords: pp
Resolution: DUPLICATE → ---
to pinkerton
Assignee: evaughan → pinkerton
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 7

17 years ago
huh? i've never seen a textarea use a native scrollbar on any platform. in 6.2,
they're gfx. what crack are you all smoking?
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

17 years ago
Created attachment 59161 [details]
Screenshot
You need to log in before you can comment on or make changes to this bug.