tbody display: none problems after document.write() in <head>

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: han.holl, Assigned: attinasi)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Linux build 2001112121

I finally got together a testcase which shows weirdness
when one has a document.write() in the HEAD element, a select
element within a <tbody>, and starts playing hide and seek.
Putting an alert after the document.write() solves the
problem in the testcase (but not in the real life case that this
is distilled from).

In the  first attachment, the two first checkboxes show
wrong behaviour. Also note that the initial display differs!

Also note that if I remove the <select> element from the table,
all is fine.

With the Linux 2001102910 build the testcases both are OK, so
it might be related to the fix for 110523.

I hope this may be of use to someone to track this problem down.
(Reporter)

Comment 1

17 years ago
Created attachment 58866 [details]
This one shows the incorrect hide/display behaviour
(Reporter)

Comment 2

17 years ago
Created attachment 58867 [details]
This one is ok, by just adding an alert('a')
(Reporter)

Comment 3

17 years ago
I just checked Linux builds 2001110821 and 2001110612 : both
display _both_ testcases incorrectly, but different from
the the incorrect display of 2001112121.
2001110612 at first displays the first attachment correctly,
but goes bad after shift/reload. There is a difference in
initial rendering between with/without alert().
layout
Assignee: asa → attinasi
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: doronr → petersen
WFM using 2002012203 build on WINXP.

peterson: Can you try Linux? Thanks!
Target Milestone: --- → Future
WORKSFORME on a fresh Linux CVS build.  Resolving WORKSFORME.  Reporter: if you
are still experiencing problems with this bug, please reopen it, and describe
what you see.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

17 years ago
Yes, works for me as well.
Whoever solved this, thanks.
You need to log in before you can comment on or make changes to this bug.