Closed Bug 11147 Opened 21 years ago Closed 21 years ago

NS_OpenURI(&in, uri) returns NS_OK even the file/uri does not exist

Categories

(Core :: Networking, defect, P3, critical)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: tao, Assigned: warrensomebody)

References

()

Details

(Whiteboard: asked reporter to verify)

nsStringBundle relies on the network service to report error
state when the file/uri does not exist. With the non-Necko
code, pNetService->OpenBlockingStream(url, nsnull, &in) return
error and cause StringBundle to fallback on file/uri with less
locale-specific names.

This fallback mechanism stops working now.
Status: NEW → ASSIGNED
Target Milestone: M9
To reproduce the bug, you can run the test program, StringBundleTest(.exe),
in bin/. It shall open "bin/res/strres.properties" since there is no
"bin/res/strres_en_US.properties".

Let me know if you need assistance reproducing the bug.


Thanks
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
I know what this is now. Thanks.
Status: RESOLVED → REOPENED
Not FIXED -- ACCEPT.
Status: REOPENED → ASSIGNED
...er I mean ASSIGNED.
Resolution: FIXED → ---
Status: ASSIGNED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
Fixed.
Whiteboard: asked reporter to verify
tao, can you verify the fix? Thanks, I only have release builds.
Status: RESOLVED → VERIFIED
QA Contact: paulmac → tao
Pulled the change on NT and Linux. Verified fixed.
Changed QA contact to myself.
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.