[Messaging][Settings] Graphical error is seen when loading the SIM settings from the Messaging app

RESOLVED DUPLICATE of bug 1137203

Status

()

RESOLVED DUPLICATE of bug 1137203
4 years ago
4 years ago

People

(Reporter: ckreinbring, Assigned: BenWa)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(URL)

(Reporter)

Description

4 years ago
Description:
When launching SIM settings from the Messaging app, a section of the page will be  white until the page is completely shown.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141222042411
2) Launch the Messages app.
3) Tap the ... in the upper right corner then tap Settings.
4) Scroll down and tap SIM 1 (or 2) in the SIM Settings section.
5) Oberve the appearance of the page as it slides in.
6) Tap the back button then repeat step 4, observing the appearance of the page each time.
  
Actual:
A portion of the screen will fail to render until the page slides in completely.  This area covers the options on the page.

Expected: 
The entire screen will appear with no graphical errors.
  
Environmental Variables:
Device: Flame 2.2 engineering (shallow flash)
BuildID: 20141222042411
Gaia: c5b03a9b40a37947d44a71eccd9017e76632f796
Gecko: c357fb08cc10
Platform Version: 37.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached video clip
(Reporter)

Comment 1

4 years ago
Taking for branch checks.
QA Contact: ckreinbring
(Reporter)

Comment 2

4 years ago
The bug repros on Flame 2.1 engineering with shallow flash.
Actual result: The section of the page containing the options will show white as the page slides in, then the options will render.

BuildID: 20141222071650
Gaia: 1a58335917b23c170d85bf821f658e964c935b23
Gecko: 5509822354a9
Platform Version: 34.0
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

--------------------------------------------------------------------------------------------------------

The bug does not repro on Flame 2.0 engineering with shallow flash.
Actual result: When the Settings button is tapped, the normal Settings page appears.

BuildID: 20141222071429
Gaia: ce83ea7b8e3fa2d1c3fd771fc22b654c18b3c381
Gecko: 7d0adaf6c447
Platform Version: 32.0
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
Flags: needinfo?(jmitchell)
NI Settings owner for blocking call / assignment  notes: please see video, not a regression (2.0 has different behavior so can not be considered 'unaffected')
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(gchang)
QA Contact: ckreinbring
NI No-Jun to see if this is a graphic issue.
Flags: needinfo?(gchang) → needinfo?(npark)
[Blocking Requested - why for this release]:
Blocking due to obvious rendering issue.  cc'ing milan for his input.
blocking-b2g: --- → 2.1?
Flags: needinfo?(npark)
Keywords: regression
(Reporter)

Comment 6

4 years ago
I noticed that there are other pages in Settings that also repro this bug:

Wi-Fi (first time only)
Call settings
Cellular & Data
Bluetooth
Homescreen
Search
Navigation
Notifications
Language
Keyboards
Firefox Accounts
Find My Device
Screen Lock
App Permissions
Browsing Privacy
Media Storage (first time only)
Application Storage
Battery
Accessibility
Help

Comment 7

4 years ago
Triage: should belongs to core/graphics
Component: Gaia::Settings → Graphics
Product: Firefox OS → Core
(Assignee)

Updated

4 years ago
Depends on: 1112332
Duplicate of this bug: 1115458
Given the occurrence of the graphical issues in various pages per comment #6, easily reproducible, I am leaning on blocking this bug to get it fixed. 

We may have to end-up doing targeted testing depending on how risky the uplift is. I'll let graphics team comment on the risk or other comments here
blocking-b2g: 2.1? → 2.1+
Assignee: nobody → bgirard
(Assignee)

Comment 11

4 years ago
Need to verify with bug 1112332.
Flags: needinfo?(bgirard)
(Assignee)

Comment 12

4 years ago
This might also be fixed with bug 1113435.
This does not reproduce in today's master, but in 2.1 and 2.2 it is still shown. Should the fixes be uplifted to 2.1 and 2.2?
The symptoms described in this bug are a combination of two bugs. One is the culling bug 1113435 which is now fixed on master and will be uplifted to 2.2. This is responsible for the dark rectangle that shows up in the video. On 2.1 there's this:

(In reply to Chris Kreinbring [:CKreinbring] from comment #2)
> The bug repros on Flame 2.1 engineering with shallow flash.
> Actual result: The section of the page containing the options will show
> white as the page slides in, then the options will render.

where the page shows white during the transition and then renders fully after the transition. This will be fixed by bug 1137203, which I expect to uplift all the way to 2.1. Since this bug is 2.1+, I'm going to dupe it to the latter as that will fix the issue seen on 2.1.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(bgirard)
Resolution: --- → DUPLICATE
Duplicate of bug: 1137203
No longer depends on: 1112332
You need to log in before you can comment on or make changes to this bug.