If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[firefox os 1.3-2.2] there is no horizontal support for "Email" & "SMS" only set to portrait

RESOLVED DUPLICATE of bug 1015806

Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 1015806
3 years ago
3 years ago

People

(Reporter: Jamie_, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141215134203

Steps to reproduce:

1.) open "Email" or SMS app
2.) new message
3.) filp the phone horizontal


Actual results:

phone stays in portrait, I had some help with finding it in the code but it is set to 
"orientation": "default',     line 48
sugest change


Expected results:

Phone should have switch to landscape for typing easily
(Reporter)

Updated

3 years ago
Flags: needinfo?(nhirata.bugzilla)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(felash)
Flags: needinfo?(asuth)
Flags: needinfo?(nhirata.bugzilla)
The bug for SMS is bug 869434.

But I think we should have something generic that could be handled by the system:
* when the keyboard is displayed
* when in landscape
=> we should display a full input in the upper half of the screen, and the keyboard in the lower half

I don't know who could decide and handle this though.
Flags: needinfo?(felash)
Since we have a SMS bug, why don't we separate this out to just email?  I think probably the PMs/UX would be the best to notify for this feature request
Component: General → Gaia::E-Mail
Flags: needinfo?(nhirata.bugzilla) → needinfo?(firefoxos-ux-bugzilla)
Duping this to the existing email landscape meta-bug.  And note that asuth@asuth.com is absolutely not me.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(asuth)
Resolution: --- → DUPLICATE
Duplicate of bug: 1015806
I think we can still have the UX input for comment 1. Although we might want to wait for the end of the ideation process.
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 5

3 years ago
Flagging Juwei: Even though this is resolved dupe, UX input is still needed on comment #1.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(jhuang)

Comment 6

3 years ago
I did have proposals for compose view (new message), please refer Bug 1023658.
And on p.6 of the spec https://bug1023658.bugzilla.mozilla.org/attachment.cgi?id=8451512
I plan to display the full body for people to type things easily.
Flags: needinfo?(jhuang)
Hi,

I think we should have this behavior broadly in the system, maybe built in the keyboard instead of doing it individually in apps.

See also my FxOS v3 idea at https://slack-files.com/T033ZPYCR-F03FPBK6M-2a0d3edb18
Flags: needinfo?(jhuang)

Comment 8

3 years ago
Hi Julien,
It indeed better if keyboard has a general behaviour setup.
Need info Omega, keyboard ux owner, to catch his attention.
Flags: needinfo?(jhuang) → needinfo?(ofeng)
A system-wise landscape keyboard is a good idea, we'll consider that in the next version.
Flags: needinfo?(ofeng)
You need to log in before you can comment on or make changes to this bug.