[MMS][Lockscreen][Status Bar] Status bar disappears when locking/unlocking device while creating an SMS via browser.

VERIFIED FIXED in 2.2 S3 (9jan)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: smiko, Assigned: apastor)

Tracking

({regression})

unspecified
2.2 S3 (9jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-Daily-Testing] [systemsfe], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Description: The status bar disappears when locking/unlocking the phone while sending a SMS via browser. 

Repro Steps:
1: Update a Flame to 20141222040204
2: Launch Browser and navigate to any site or search result.
3: Open the context menu and select Share > Message. (note the status bar does not repaint when opening Messages.)
4: While in Message creation, lock and unlock the DUT.

Actual: The status bar does not appear 

Expected: The status bar is displayed. 

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141222040204
Gaia: ca6e91e09ef3ab417a0f6b6d6668d43597d85700
Gecko: b915a50bc6be
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Notes:
1: May be related to Bug 1082521.

Repro Rate: 5/5

See attached logcat

Video clip: http://youtu.be/ahvP0no-c4U
(Reporter)

Comment 1

4 years ago
This issue does NOT occur on Flame 2.1 (319mb/full flash)

Actual result:
The status bar is painted white and remains after locking/unlocking the device.

Flame 2.1
Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141222001236
Gaia: 6af3d029bae3a14f400fec0926f0f8ad7b579b4b
Gecko: 39eaa987093b
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.2-Daily-Testing]
Bad User Experience regression,

requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: ckreinbring
I noticed that when on the SMS page after tapping the Share button, the status bar contents are shown in grey on the builds that repro the bug.

Regression window
Last working
BuildID: 20141218045202
Gaia: 58734e8a48157f99d5b733412b600c2e04c954fe
Gecko: 9bb8b0b4daae
Platform Version: 37.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First broken
BuildID: 20141218142705
Gaia: 2650bae535e15eef5f299cc80d4fab460f78ada7
Gecko: 121e801ae044
Platform Version: 37.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Working Gaia / Broken Gecko = No repro
Gaia: 58734e8a48157f99d5b733412b600c2e04c954fe
Gecko: 121e801ae044
Broken Gaia / Working Gecko = Repro
Gaia: 2650bae535e15eef5f299cc80d4fab460f78ada7
Gecko: 9bb8b0b4daae
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/58734e8a48157f99d5b733412b600c2e04c954fe...2650bae535e15eef5f299cc80d4fab460f78ada7


B2G Inbound
Last working
BuildID: 20141218042802
Gaia: 99be66baf4146835bed70e8105c2b8934af5cb7d
Gecko: 577aefbf76c3
Platform Version: 37.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First broken
BuildID: 20141218050403
Gaia: a1ec2268e7b467aa0ff07a2a3cbd1b9abc4e4dd1
Gecko: 32d360316ff3
Platform Version: 37.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Working Gaia / Broken Gecko = No repro
Gaia: 99be66baf4146835bed70e8105c2b8934af5cb7d
Gecko: 32d360316ff3
Broken Gaia / Working Gecko = Repro
Gaia: a1ec2268e7b467aa0ff07a2a3cbd1b9abc4e4dd1
Gecko: 577aefbf76c3
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/99be66baf4146835bed70e8105c2b8934af5cb7d...a1ec2268e7b467aa0ff07a2a3cbd1b9abc4e4dd1
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
caused by the patch to Bug 1074332 - can you take a look Alberto?
Blocks: 1074332
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(apastor)
QA Contact: ckreinbring
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(apastor)
Resolution: --- → DUPLICATE
Duplicate of bug: 1113482
(Assignee)

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

4 years ago
Whiteboard: [2.2-Daily-Testing] → [2.2-Daily-Testing] [systemsfe]
(Assignee)

Updated

4 years ago
Assignee: nobody → apastor
(Assignee)

Updated

4 years ago
Attachment #8543246 - Flags: review?(alive)
(Assignee)

Comment 7

4 years ago
The problem here is that, now that we have one statusbar per app, we should check only the parent appWindow (note that in inline activities we have the main app window, and the nested inline window).
Comment on attachment 8543246 [details] [review]
[PullReq] albertopq:1114764-statusbar-sms to mozilla-b2g:master

LGTM
Attachment #8543246 - Flags: review?(alive) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
blocking-b2g: 2.2? → 2.2+
Target Milestone: --- → 2.2 S3 (9jan)
*2.2
Build ID               20150326164141
Gaia Revision          6d0174e28576f2f93e696a43d1ac3b03340117f6
Gaia Date              2015-03-26 21:47:33
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/820c2f2e817a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150326.201153
Firmware Date          Thu Mar 26 20:12:05 EDT 2015
Bootloader             L1TC000118D0

*master
Build ID               20150326160206
Gaia Revision          525c341254e08f07f90da57a4d1cd5971a3cc668
Gaia Date              2015-03-26 16:34:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/59554288b4eb
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150326.193247
Firmware Date          Thu Mar 26 19:32:58 EDT 2015
Bootloader             L1TC100118D0
Status: RESOLVED → VERIFIED

Comment 11

4 years ago
Per comment 10, clear "verifyme" keyword
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.