Apprunner crashes - Talkback Incident ID #11930702

VERIFIED FIXED

Status

()

Core
RDF
P3
normal
VERIFIED FIXED
19 years ago
10 months ago

People

(Reporter: Christine Hoffman, Assigned: rickg)

Tracking

Trunk
All
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Using 8/2 Apprunner on Win 95, Win NT, Win 98, Mac 8.5 and Linux.

Open Apprunner. Select Bookmarks/Manage Bookmarks. Click back and forth between
columns. Application crashes with the following details:

APPRUNNER caused an invalid page fault in
module RAPTORHTML.DLL at 0137:604780cb.
Registers:
EAX=00000000 CS=0137 EIP=604780cb EFLGS=00010246
EBX=0063c3d8 SS=013f ESP=0063c2ec EBP=0063c2f4
ECX=00000000 DS=013f ESI=0063c348 FS=0fdf
EDX=0063c3e0 ES=013f EDI=0063c3dc GS=0000
Bytes at CS:EIP:
8a 00 59 3a c1 74 04 3c 03 75 05 6a 04 5e eb 47
Stack dump:
00000002 0063c348 0063c320 60478059 0987dcf0 00000000 00000000 0987d1f0 0063c348
00000000 60477fa3 0981d720 0063c484 0063c44c 604c6784 0981d720

CALL STACK - Incident ID #11930702:
Call Stack:    (Signature = RAPTORHTML.DLL + 0x280cb (0x604780cb)
c5244d2f)
RAPTORHTML.DLL + 0x280cb (0x604780cb)
RAPTORHTML.DLL + 0x28059 (0x60478059)
RAPTORHTML.DLL + 0x27fa3 (0x60477fa3)
RAPTORHTML.DLL + 0x76784 (0x604c6784)
RAPTORHTML.DLL + 0x77219 (0x604c7219)
RAPTORHTML.DLL + 0x2789a (0x6047789a)
RAPTORHTML.DLL + 0x74574 (0x604c4574)
RAPTORHTML.DLL + 0x73426 (0x604c3426)
RAPTORHTML.DLL + 0x73097 (0x604c3097)
RAPTORHTML.DLL + 0x81635 (0x604d1635)
RAPTORHTML.DLL + 0x2789a (0x6047789a)
RAPTORHTML.DLL + 0x7b7ec (0x604cb7ec)
RAPTORHTML.DLL + 0x7b6c7 (0x604cb6c7)
RAPTORHTML.DLL + 0x7b360 (0x604cb360)
RAPTORHTML.DLL + 0x7bedb (0x604cbedb)
RAPTORHTML.DLL + 0x3162e (0x6048162e)
RAPTORHTML.DLL + 0x2ebb6 (0x6047ebb6)
RAPTORHTML.DLL + 0x2e3ec (0x6047e3ec)
RAPTORHTML.DLL + 0x2e15a (0x6047e15a)
RAPTORHTML.DLL + 0x2da41 (0x6047da41)
RAPTORHTML.DLL + 0x9918c (0x604e918c)
RAPTORHTML.DLL + 0x2789a (0x6047789a)
RAPTORHTML.DLL + 0x18c60 (0x60468c60)
RAPTORHTML.DLL + 0x2789a (0x6047789a)
RAPTORHTML.DLL + 0x99b92 (0x604e9b92)
RAPTORHTML.DLL + 0x29f44 (0x60479f44)
RAPTORHTML.DLL + 0x24435 (0x60474435)
RAPTORHTML.DLL + 0x2399f (0x6047399f)
RAPTORHTML.DLL + 0x24d7a (0x60474d7a)
RDF.DLL + 0x15781 (0x60575781)
RDF.DLL + 0x1de63 (0x6057de63)
RDF.DLL + 0xd532 (0x6056d532)
RDF.DLL + 0xc2f3 (0x6056c2f3)
RDF.DLL + 0x5cff (0x60565cff)
RDF.DLL + 0x9c21 (0x60569c21)
RDF.DLL + 0x55ae (0x605655ae)
RDF.DLL + 0x41d7 (0x605641d7)
RDF.DLL + 0xcb2b (0x6056cb2b)
RDF.DLL + 0x171ec (0x605771ec)
RDF.DLL + 0x1d10f (0x6057d10f)
JSDOM.DLL + 0x15397 (0x60915397)
JS3250.DLL + 0x134dd (0x608d34dd)
JS3250.DLL + 0x172e3 (0x608d72e3)
JS3250.DLL + 0x1351a (0x608d351a)
JS3250.DLL + 0x172e3 (0x608d72e3)
JS3250.DLL + 0x13776 (0x608d3776)
JS3250.DLL + 0x391f (0x608c391f)
JSDOM.DLL + 0x50f6 (0x609050f6)
JSDOM.DLL + 0x5015 (0x60905015)
JSDOM.DLL + 0x3bb62 (0x6093bb62)
JSDOM.DLL + 0x3b95f (0x6093b95f)
JSDOM.DLL + 0x3b87e (0x6093b87e)
KERNEL32.DLL + 0x241d (0xbff7241d)
USER32.DLL + 0x3372 (0xbff63372)
Registers:
EAX: 00000000
EBX: 0063c3d8
ECX: 00000000
EDX: 0063c3e0
ESI: 0063c348
EDI: 0063c3dc
ESP: 0063c2ec
EBP: 0063c2f4
EIP: 604780cb
cf PF af ZF sf of IF df nt RF vm   IOPL: 0
CS:  0137
DS:  013f
SS:  013f
ES:  013f
FS:  0fdf
GS:  0000

Not sure where to categorize this.

Updated

19 years ago
Assignee: waterson → rjc

Comment 1

19 years ago
Looks like sort. RJC: lucky you.

Updated

19 years ago
Assignee: rjc → rickg

Comment 2

19 years ago
This looks like Raptor to me! Rickg?
(Assignee)

Updated

19 years ago
Assignee: rickg → petersen
(Assignee)

Comment 3

19 years ago
Chris -- I don't seem to be able to reproduce this. Can you verify?

Comment 4

19 years ago
I can't reproduce the crash described in the original description. This was
tested on Windows 95 and Windows 98 usingthe Aug 16th build. The Aug 16th Mac
build will crash after selecting Manage Bookmarks from the Bookmarks menu. This
seems to be a new crash since it was working in previous builds.

Updated

19 years ago
Assignee: petersen → rickg
(Reporter)

Comment 5

19 years ago
Rick:
No longer crashing with 8/16 Apprunner. However, now Mac crashes when selecting
Bookmarks/Manage Bookmarks (new bug filed #11993) and on Win and Linux platforms
when toggling between columns under 'Bookmarks' a new window opens up (new bug
filed #11996).

This bug appears fixed.
(Reporter)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

19 years ago
Marking per 8/16 comments
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

19 years ago
Verified fixed.
You need to log in before you can comment on or make changes to this bug.