timingtool.com - Page uses invalid javascript to change the size of applet

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
4 years ago

People

(Reporter: paul.chaffey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Goto the timingtool website and hit the demo button. When the pop-up frame
appears with timingtool within a frame, the applet does not resize when the frame
is resized. This works fine on IE but not with netscape 6.1 or mozilla 0.96 ??

Comment 1

17 years ago
dup of bug 86045?

Comment 2

17 years ago
WFM. Build ID: 2001 11 20 03. Windows 2000.

So this is a Linux-only problem? But bug 86045 says "OS: Windows 2000". Hmm...

Comment 3

17 years ago
I must say i don't quite understand what reporter is seeing.
I see that the window doesn't get scrollbars when I resize the window,
and app itself has one size, regardless of windowsize.
The size of the app is the same regardless of windowsize on NS4.77 and a current
Mozilla CVS build, Linux. (But NS4.77 adds scrollbars when sizing the window
smaller than the app.)

I see this warning in console as the app opens in Mozilla:

 Warning: 
    Name: HorScrollBar
    Class: XmScrollBar
    The specified scrollbar value is greater than the maximum
    scrollbar value minus the scrollbar slider size.

Comment 4

17 years ago
->Plugins
Assignee: asa → av
Component: Browser-General → Plug-ins
QA Contact: doronr → shrir

Comment 5

17 years ago
I am going to confirm this bug because I see the same problem as the reporter.

Steps to reproduce:
1. Visit http://www.timingtool.com/
2. Click on the DEMO button
3. Try to resize the resulting window

Expected
Applet to change it size with the window

Result
Applet stays the same size regardless of changes to the window size

The page containing the applet
(http://www.timingtool.com/php/try_me_loader.php?framename=tool3cbe9ca3ad67d)
contains some javascript to resize the applet when the window is resized however
making the window bigger or smaller does not change the area used by the applet.
However, a quick look in the Javascript console shows this:

Warning: reference to undefined property document.mainApplet.setSize
Source File:
http://www.timingtool.com/php/try_me_loader.php?framename=tool3cbe9ca3ad67d
Line: 45

So the error is within the javascript on the page. This is quite possibly an
evangelism bug because the page author needs to update their javascript to be
moz compatible. It would be nice if the page author could be informed about the
correct way to do this that supports moz.

2002041707 Linux

Confirming and shunting to Browser General for further evaluation
Status: UNCONFIRMED → NEW
Component: Plug-ins → Browser-General
Ever confirmed: true
Summary: Java applet does not get resized within a frame → Page uses invalid javascript to change the size of applet

Comment 6

17 years ago
reassign owner
Assignee: av → Matti
QA Contact: shrir → imajes-qa
-> TE
Assignee: Matti → doron
Component: Browser-General → US General
Product: Browser → Tech Evangelism
QA Contact: imajes-qa → zach
Version: other → unspecified

Updated

16 years ago
Summary: Page uses invalid javascript to change the size of applet → timingtool.com - Page uses invalid javascript to change the size of applet

Comment 8

16 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us
I can't see a demo button there.
Is this now fixed ?

Comment 10

8 years ago
The new "DEMO" page is here ==> http://www.timingtool.com/tt_lite

This is WFM.

Firefox 3.6.9 ==> http://yfrog.com/5n111480ffxp
IE8 ==> http://yfrog.com/jw111480ie8p
according to Comment #10
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.