[Browser] Web video will appear in portrait when device in landscape

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System::Window Mgmt
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Jeremiah Lee, Assigned: etienne)

Tracking

({regression})

unspecified
2.2 S3 (9jan)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-exploratory-2][systemsfe], URL)

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

3 years ago
Created attachment 8540405 [details]
webvideoportrait_logcat.txt

Description:
When youtube video is displayed in portrait mode then going to card view, tilting device into landscape and returning to youtube will cause video to remain in portrait view while in landscape mode (video will be sized as if still in portrait mode).
   
Repro Steps:
1) Update a Flame device to BuildID: 20141222040204
2) Open Browser > Go to youtube > play a video in portrait
3) In portrait, hold down Home button to go to card view
tilt device in landscape > tap on browser to go back to youtube video
4) Observe
  
Actual:
Going to card view with video in portrait mode, video will remain in portrait view when returning to youtube video with device tilted to landscape.
  
Expected: 
Going to card view with video in portrait mode, video will adjust to current view/landscape when returning to youtube video with device tilted to landscape.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141222040204
Gaia: ca6e91e09ef3ab417a0f6b6d6668d43597d85700
Gecko: b915a50bc6be
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Notes: Issue also occurs on vimeo video site.
  
Repro frequency: 4/4, 100%
See attached: video clip (http://youtu.be/_t8uQ_Bf8Ws), logcat (webvideoportrait_logcat.txt)
(Reporter)

Comment 1

3 years ago
Issue does not occur on Flame 2.1 or Flame 2.0.

Going to card view with video in portrait mode, video will adjust to current view/landscape when returning to youtube video with device tilted to landscape.

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141222001236
Gaia: 6af3d029bae3a14f400fec0926f0f8ad7b579b4b
Gecko: 39eaa987093b
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141222000200
Gaia: ce83ea7b8e3fa2d1c3fd771fc22b654c18b3c381
Gecko: 752225b5d185
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

This is basic user functionality. Easy to reproduce. Nominating to block 2.2
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Keywords: regressionwindow-wanted
QA Contact: jmercado
Whiteboard: [2.2-exploratory-2] → [2.2-exploratory-2][systemsfe]
Bug 1106855 seems to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141219022805
Gaia: 9471af2ff4e995a0d9785ced2073c8fa9c8c357c
Gecko: f2dd62ae2d63
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141219025805
Gaia: 8a7377c1a75c25b90313f4d4606c7c25bab3a03a
Gecko: 0bca81667b0d
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: 9471af2ff4e995a0d9785ced2073c8fa9c8c357c
Gecko: 0bca81667b0d

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: 8a7377c1a75c25b90313f4d4606c7c25bab3a03a
Gecko: f2dd62ae2d63

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/9471af2ff4e995a0d9785ced2073c8fa9c8c357c...8a7377c1a75c25b90313f4d4606c7c25bab3a03a
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
NI on Alive, appears issue was caused by patch for bug 1106855, can you take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(alive)
Assignee: nobody → alive
Flags: needinfo?(alive)

Comment 5

3 years ago
Created attachment 8543834 [details] [review]
[PullReq] alivedise:bugzilla/1106855/do-not-check-frame-size-on-resizing to mozilla-b2g:master
Comment on attachment 8543834 [details] [review]
[PullReq] alivedise:bugzilla/1106855/do-not-check-frame-size-on-resizing to mozilla-b2g:master

So it seems redundant to check frame size while force resizing - because the inner iframe is resized by someone else but the outer container is not. I think we have  to check who is doing that and why doing that, but in order to avoid regression again let's remove the check inside _resize. Not sure how to write test for it, be listening if you have ideas.
Attachment #8543834 - Flags: review?(etienne)
(Assignee)

Comment 7

3 years ago
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #6)
> Comment on attachment 8543834 [details] [review]
> [PullReq] alivedise:bugzilla/1106855/do-not-check-frame-size-on-resizing to
> mozilla-b2g:master
> 
> So it seems redundant to check frame size while force resizing - because the
> inner iframe is resized by someone else but the outer container is not. I
> think we have  to check who is doing that and why doing that, but in order
> to avoid regression again let's remove the check inside _resize. Not sure
> how to write test for it, be listening if you have ideas.

I think I found the root cause, and it's my fault.
So I'll go ahead and still this, hope you don't mind :)
(Assignee)

Updated

3 years ago
Assignee: alive → etienne
(Assignee)

Updated

3 years ago
Attachment #8543834 - Attachment is obsolete: true
Attachment #8543834 - Flags: review?(etienne)
(In reply to Etienne Segonzac (:etienne) from comment #7)
> (In reply to Alive Kuo [:alive][NEEDINFO!] from comment #6)
> > Comment on attachment 8543834 [details] [review]
> > [PullReq] alivedise:bugzilla/1106855/do-not-check-frame-size-on-resizing to
> > mozilla-b2g:master
> > 
> > So it seems redundant to check frame size while force resizing - because the
> > inner iframe is resized by someone else but the outer container is not. I
> > think we have  to check who is doing that and why doing that, but in order
> > to avoid regression again let's remove the check inside _resize. Not sure
> > how to write test for it, be listening if you have ideas.
> 
> I think I found the root cause, and it's my fault.
> So I'll go ahead and still this, hope you don't mind :)

\O/

Comment 9

3 years ago
Created attachment 8543961 [details] [review]
[PullReq] etiennesegonzac:bug-1114800 to mozilla-b2g:master

Comment 10

3 years ago
Created attachment 8543962 [details] [review]
[PullReq] etiennesegonzac:bug-1114800 to mozilla-b2g:master
(Assignee)

Comment 11

3 years ago
Comment on attachment 8543962 [details] [review]
[PullReq] etiennesegonzac:bug-1114800 to mozilla-b2g:master

Added comments too, let me know if it's not clear enough.
Attachment #8543962 - Flags: review?(alive)
Comment on attachment 8543961 [details] [review]
[PullReq] etiennesegonzac:bug-1114800 to mozilla-b2g:master

Not sure why autolander tried to process it twice, but I'll obsolete for now and look into it. Thanks for letting me know.
Attachment #8543961 - Attachment is obsolete: true
Regression
blocking-b2g: 2.2? → 2.2+
Target Milestone: --- → 2.2 S3 (9jan)
Comment on attachment 8543962 [details] [review]
[PullReq] etiennesegonzac:bug-1114800 to mozilla-b2g:master

r=me, thanks!
Attachment #8543962 - Flags: review?(alive) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Comment 15

3 years ago
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.

Note: Until bug 1095028 lands, the patch *must* have a review by a suggested reviewer. If you are the patch author, you can leave an additional R+ on the attachment for autolander to process it.

Updated

3 years ago
Keywords: checkin-needed

Comment 16

3 years ago
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.

Note: Until bug 1095028 lands, the patch *must* have a review by a suggested reviewer. If you are the patch author, you can leave an additional R+ on the attachment for autolander to process it.
(Assignee)

Updated

3 years ago
Component: Gaia::Browser → Gaia::System::Window Mgmt
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Comment 17

3 years ago
Pull request has landed in master: https://github.com/mozilla-b2g/gaia/commit/a1d2ad69cb9983c457ccb0e4ea9e744815fa918b

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
status-b2g-v2.2: affected → fixed
Depends on: 1122324
Keywords: verifyme
According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v2.2.

Actual results: Going to card view with video in portrait mode, video will adjust to current view/landscape when returning to youtube video with device tilted to landscape.

See attachment: verified_v2.2.MP4.
Reproduce rate: 0/5

Device: Flame 2.2 build(Pass)
Build ID               20150327162502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b358619def45
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.194944
Firmware Date          Fri Mar 27 19:49:53 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
Keywords: verifyme
Created attachment 8584922 [details]
verified_v2.2.mp4
You need to log in before you can comment on or make changes to this bug.