[B2G] [gaia] [keyboard] german dictionary not setting up right for auto correct

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Jamie_, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141215134203

Steps to reproduce:

ubuntu 14.10 firefox developers edition webIDE simulator for 1.3-2.2

curtesy of nhirata_  
    Build ID               20141222001236
    Gaia Revision          6af3d029bae3a14f400fec0926f0f8ad7b579b4b
    Gaia Date              2014-12-18 14:51:16
    Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/39eaa987093b
    Gecko Version          34.0
    Device Name            flame
    Firmware(Release)      4.4.2
    Firmware(Incremental)  eng.cltbld.20141222.035139
    Firmware Date          Mon Dec 22 03:51:49 EST 2014
    Bootloader             L1TC00011880 
1.)change language settings to german
2.) check and it shows german keyboard is active in settings
3.) go to an area to type that allows auto correct (messaging is easiest)
4.) proceed to type in german


Actual results:

the phone started auto correcting to English words instead of German words 


Expected results:

auto correct should have started to correct in german instead of english
(Reporter)

Comment 1

4 years ago
delphine
Flags: needinfo?(lebedel.delphine)
Naoki: can you confirm that this happens on your side as well? I wasn't able to repro on mine. thanks!
Flags: needinfo?(lebedel.delphine) → needinfo?(nhirata.bugzilla)
(Reporter)

Comment 3

4 years ago
In 1.3 the auto correct dosent seem to even be working at all, 1.4 isnt working either, 2.0 isnt, 2.1 isnt, and i cant seem to get 2.2 to work either :delphine its not working in the simulator, i need a way to reset the simulators so i can get exact results.
I was able to check against 2.0, 2.1 and 2.2 branches on Flame device and I cannot reproduce this. 
Which is why this leads me to think that this is a simulator specific bug.
Adding :ochameau as I think he was leading the simulator effort, to see if he can give any input about this.
Flags: needinfo?(nhirata.bugzilla)
Keyboard developers, any idea why the right dictionaries wouldn't be used on b2g desktop??
I verified, we do ship the dicts in keyboard's application.zip:
js/imes/latin/dictionaries/fr.dict
js/imes/latin/dictionaries/es.dict
js/imes/latin/dictionaries/pt_br.dict
js/imes/latin/dictionaries/de.dict
js/imes/latin/dictionaries/pl.dict
js/imes/latin/dictionaries/en_us.dict

I looked at keyboard codebase but wasn't able to see on which setting/navigator api keyboard is using to check which language to use.
Component: Simulator → Gaia::Keyboard
(Reporter)

Comment 6

4 years ago
okay I figure out what the problem was, the keyboard for English was on still... even know it was not the one in use, I fixed it just by disabling the English keyboard and it started to correct to German instead of English.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.