Closed Bug 1114864 Opened 6 years ago Closed 6 years ago

Request to add Igbo (ig) keyboard to Firefox OS

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 fixed, b2g-v2.1S fixed, b2g-v2.2 fixed, b2g-master verified)

RESOLVED FIXED
2.2 S13 (29may)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- fixed
b2g-v2.1S --- fixed
b2g-v2.2 --- fixed
b2g-master --- verified

People

(Reporter: delphine, Assigned: rudyl, NeedInfo)

References

Details

Attachments

(6 files, 2 obsolete files)

Request to add Igbo (ig) locale to Firefox OS
[Blocking Requested - why for this release]:
Requested for 2.0 and onwards. Thus nominating
blocking-b2g: --- → 2.0?
Flags: needinfo?(bbajaj)
[Blocking Requested - why for this release]:

[Triage] Considering current 2.0 timing and the need from partner, nom. to 2.1 (or even 2.2?) instead for consideration.
blocking-b2g: 2.0? → 2.1?
Clearing blocking nom, refer to comment in : https://bugzilla.mozilla.org/show_bug.cgi?id=1114866
blocking-b2g: 2.1? → ---
Flags: needinfo?(bbajaj)
Adding localizers who might be able to help in the meantime with keyboard input. thanks!
Flags: needinfo?(soki2ng)
Flags: needinfo?(mcsteann)
No answer from localizers, so asking Peiying if she can plug in Rubric to help with review, as well as Bruce so he can help drive this on the keyboard side.
Thanks all!
Flags: needinfo?(pmo)
Flags: needinfo?(bhuang)
Layout here for review: http://goo.gl/vApmyz.

Adding to backlog.
blocking-b2g: --- → backlog
Flags: needinfo?(bhuang)
+ Devon & Ian
Our translator has indicated this keyboard is a complete Igbo keyboard: http://www.stars21.com/keyboard/igbo_keyboard.html
blocking-b2g: backlog → ---
Is there anything else needed from me for this?
Bruce: keyboard feedback is given in comment 8. 
Blocking 2.1 on this as per the mana (cross-functional view).
Please let us know if you need any thing else!
blocking-b2g: --- → 2.1+
Flags: needinfo?(pmo) → needinfo?(bhuang)
Confirmed that the letters are all available as indicated in comment 8.  I had to modify to fit in our standard layout since that link just indicates all available letters.

http://goo.gl/vApmyz

Rudy, can you check and see if you have any questions on the layout?
Flags: needinfo?(bhuang) → needinfo?(rlu)
Comment on attachment 8602079 [details] [review]
[gaia] RudyLu:keyboard/Bug1114864-igbo_layout > mozilla-b2g:master

The layout is ready for review.

--
Arky, could you please give feedback on the layout?
Beside, please help review that "Asụsụ Igbo" is the correct (native) name for this layout.
Thanks.
Flags: needinfo?(rlu)
Attachment #8602079 - Flags: review?(timdream)
Attachment #8602079 - Flags: feedback?(hitmanarky)
Assignee: nobody → rlu
Status: NEW → ASSIGNED
Attachment #8602079 - Flags: review?(timdream) → review+
Screenshots of Igbo keyboard including secondary characters.
Ian and Devon, 

Please review the layout in comment #14 and confirm whether it is ok.  There is minor font issue the team is still trying to resolve but the work won't affect the layout.
Hello All,

Our Igbo translators confirmed that the layout of the keyboard is correct.

Thank you,
Devon
Comment on attachment 8602079 [details] [review]
[gaia] RudyLu:keyboard/Bug1114864-igbo_layout > mozilla-b2g:master

Take comment 16 as a feedback+ on this patch.

Thanks.
Attachment #8602079 - Flags: feedback?(hitmanarky) → feedback+
http://docs.taskcluster.net/tools/task-graph-inspector/#H3Mw6mD4TPqUvcv-cj4EHQ

The pull request failed to pass integration tests. It could not be landed, please try again.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Please request Gaia v2.1 and v2.2 approval on this when you get a chance.
Flags: needinfo?(rlu)
Target Milestone: --- → 2.2 S13 (29may)
Comment on attachment 8602079 [details] [review]
[gaia] RudyLu:keyboard/Bug1114864-igbo_layout > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined:
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature, a new keyboard layout.
[User impact] if declined: No Igbo layout for Igbo users.
[Testing completed]: Manually by patch author
[Risk to taking this patch] (and alternatives if risky): Low since this layout won't be built by default unless explicitly set for each branch.
[String changes made]: N/A.
Flags: needinfo?(rlu)
Attachment #8602079 - Flags: approval-gaia-v2.2?
Attachment #8602079 - Flags: approval-gaia-v2.1?
Please don't uplift to v2.1 since we would need a branch-specific patch for that.
Thanks.
Comment on attachment 8602079 [details] [review]
[gaia] RudyLu:keyboard/Bug1114864-igbo_layout > mozilla-b2g:master

Approving as this only add new keyboard layout.

Hi Vance,
Do we have any release plan for 2.1 devices?
Thanks!
Flags: needinfo?(vchen)
Attachment #8602079 - Flags: approval-gaia-v2.2?
Attachment #8602079 - Flags: approval-gaia-v2.2+
Attachment #8602079 - Flags: approval-gaia-v2.1?
Attachment #8602079 - Flags: approval-gaia-v2.1-
Yes, we might have partners from Nigeria that want this keyboard for 2.1s as well...Would it be too difficult to uplift it to 2.1s ?

Thanks
Flags: needinfo?(vchen)
Comment on attachment 8602079 [details] [review]
[gaia] RudyLu:keyboard/Bug1114864-igbo_layout > mozilla-b2g:master

Hi Vance,
Thanks for the info.

@Rudy,
Please raise 2.1 uplift approval when you have 2.1 branch patch ready.
Thanks!
Flags: needinfo?(rlu)
Attachment #8602079 - Flags: approval-gaia-v2.1+ → approval-gaia-v2.1-
This bug has been verified as "pass" on latest build of Flame 3.0, Nexus5_3.0.
STR:
1. Launch Settings->keyboard.
**The Asusu Igbo keyboard can be found in the list.
2. Check Asusu Igbo keyboad.
3. Launch Message, create a new message.
4. Try to change keyboard to Asusu Igbo.
**Keyboard is changed successfully.

Actual result:The Igbo keyboard has been added to device.

See attachment:Verify3.0.3gp
Reproducing rate: 0/5

Device: Flame 3.0 build(Pass):
Build ID               20150614010203
Gaia Revision          1bf2da102560481748ff3f6202fbed5c4daa5832
Gaia Date              2015-06-13 00:22:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c223b8844264
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150614.044513
Firmware Date          Sun Jun 14 04:45:25 EDT 2015
Bootloader             L1TC000118D0

Device:Nexus5_3.0 build(Pass):
Build ID               20150614010203
Gaia Revision          1bf2da102560481748ff3f6202fbed5c4daa5832
Gaia Date              2015-06-13 00:22:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c223b8844264
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150614.044149
Firmware Date          Sun Jun 14 04:42:08 EDT 2015
Bootloader             HHZ12f
QA Whiteboard: [MGSEI-Triage+]
Attached video Verify3.0.3gp
This needs rebasing for v2.2 as well.
Attached file Patch for v2.2
Flags: needinfo?(rlu)
Comment on attachment 8622983 [details] [review]
Patch for v2.1

Now, the patches for both v2.2 and v2.1 are ready.
See comment 21 for the approval request reasons.

Thanks.
Attachment #8622983 - Flags: approval-gaia-v2.1?
Comment on attachment 8622983 [details] [review]
Patch for v2.1

Approving as branch patch provided.
Attachment #8622983 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Attached video 2.2_Fail.3gp (obsolete) —
Attached file logcat_0927.txt (obsolete) —
For v2.2, you have to specify including the newly added keyboard layout when building Gaia,
  |GAIA_KEYBOARD_LAYOUTS=en,pt-BR,es,de,fr,fr-CA,pl,ko,zh-Hans-Pinyin,en-Dvorak,ig make install-gaia|

or, it won't be built.

Could you please help verify it again with the above addition?
Thanks.
Flags: needinfo?(liuyong)
Flags: needinfo?(jocheng)
Flags: needinfo?(liuyong)
Hi Rudy,
We add these keyboards by follow steps:

1. Clone following language files to gaia/locals folder: de,es,en-US,fr,ig,pt-BR,ko,pl,zh-CN, and add a file named language.json in which you should place the required languages. Then add the .userconfig to flame-kk folder, and add the following command:
export LOCALE_BASEDIR=/home/workspace/flame-kk/gaia/locales
export LOCALES_FILE=/home/workspace/flame-kk/gaia/locales/languages.json
export GAIA_DEFAULT_LOCALE=de,es,en-US,fr,ig,pt-BR,ko,pl,zh-CN
export GAIA_KEYBOARD_LAYOUTS=en,pt-BR,es,de,fr,fr-CA,pl,ko,zh-Hans-Pinyin,en-Dvorak,ig
2.Build and flash this gaia.

Verify the bug with this build, the result is "Pass". Could you help to check it? Thanks!
Attachment:Verify_2.2.3gp
Flags: needinfo?(rlu)
Attached video Verify_2.2.3gp
Attachment #8626433 - Attachment is obsolete: true
Attachment #8626432 - Attachment is obsolete: true
Thanks for your help to re-verify this issue on v2.2.
I think the test steps look good to me.

Thanks.
Flags: needinfo?(rlu)
You need to log in before you can comment on or make changes to this bug.