Status

SeaMonkey
General
--
blocker
RESOLVED INVALID
16 years ago
12 years ago

People

(Reporter: Blake Ross, Assigned: Suresh Duddi (gone))

Tracking

({smoketest})

Trunk
x86
Windows 2000
smoketest

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Times used to be in the 7.10-7.30 ms range for tbox...they're now in the 7.60-
7.70 range.
(Reporter)

Updated

16 years ago
Keywords: smoketest

Comment 1

16 years ago
Perhaps related: bug 73382. Why is the keyword "smoketest" used here?
(Reporter)

Comment 2

16 years ago
Because the keyword we use to designate bugs that should hold the tree closed is
poorly named.

Comment 3

16 years ago
You misunderstand: I meant to ask which smoketest you are refering to?

But perhaps it's me who misunderstand - is "TB" = Tinderbox? Startup times there
have been around 7s the past 4 hours. Perhaps I'm looking at the wrong Tinderbox?

Comment 4

16 years ago
dupe of bug 110340

Bug 73382 seems to affect page load time, but not startup time, atleast by tbox 
numbers. start-up time being up was affected by some checkin or another on 11/14

http://bonsai.mozilla.org/showcheckins.cgi?&batchid=670
The startup time test still shows a lot of random variation.  I don't think it's
stable enough to be filing bugs like this, never mind cc:ing half the world.  In
particular, the numbers seem, without any checkins happening, to gradually
increase for a period of time and then suddenly fall back to where they started
(or perhaps not quite as low as where they started).

Anyway, the numbers on sleestack (which is probably the tinderbox you were
watching) did their little fall (from 7.76s to 6.99s) around 16:00 PDT on 11/22,
so marking INVALID.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

16 years ago
Uh...I didn't cc anyone. Mike did that, but I don't have a clue why.

As for the numbers, no, I disagree. They remained in that range for days.  I'm
pretty sure they only dropped to the low level they're at now because of your or
someone else's checkins, which also had a significant effect on new window time.
The drop in startup time happened after a bunch of no-op checkins.  Inside the
firewall (somebody's working on getting them outside), we have graphs of the
startup times for openwound, which is currently just running the startup test
and not pulling any checkins.  It's quite clear what is happening.  It's pretty
clear even if you just look at the times on
http://tinderbox.mozilla.org/showbuilds.cgi?tree=SeaMonkey-Testerbox&hours=60 
(FWIW, I don't think sleestack is starting with a fresh profile each time.)
Created attachment 59006 [details]
sleestack tinderbox startup times

The sleestack tinderbox is the tinderbox on the main page running the startup
tests.	This graph shows the recent drop that wasn't related to any checkins. 
(My leak fix wouldn't have affected startup time -- it would only affect new
window time for windows after the first, and only that after some windows had
been closed.)
Created attachment 59007 [details]
openwound tinderbox startup times

For the past few days, openwould has been running without taking any checkins. 
The end part of this graph shows a very clear pattern.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.