If a new tab page is set via a default preference, it randomly doesn't work.

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: mkaply, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
This is a weird one.

If you use an AutoConfig file to set the default new tab page and start opening new tab pages, occasionally it simply doesn't work.

I'm going to provide a recreation scenario that doesn't use AutoConfig simply because it is easier.

Create a file in:

browser\defaults\preferences\

Called prefs.js that contains

pref("browser.newtab.url", "http://example.com");

Start the browser.

Hit Ctrl+T a few times. Notice that about:newtab pages are intermingled with your new tab page.

On Nightly, the problem is a little different but still happens. If you look at the title of the new tabs, sometimes it's the web page, sometimes it is "New Tab".
(Reporter)

Comment 1

2 years ago
Can't set new tab via preferene anymore.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.