Compositor hang with Intel driver (on Fedora 21)

RESOLVED DUPLICATE of bug 1069523

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 1069523
4 years ago
3 years ago

People

(Reporter: overholt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8540756 [details]
hang-backtrace.txt

Since updating to Fedora 21 (this is a guess but it could be coincidental) I've had a *lot* of hangs with nightly and my normal profile.  It's not super-simple to reproduce as it seems to happen randomly after an hour or more of usage.  I'd try it with a clean profile but it would be a bit harder to reproduce there.

Fedora 21
x86_64
non-e10s nightly (both from mozilla.org and locally-built)

I reproduced it with my own local build (somewhere around http://hg.mozilla.org/mozilla-central/rev/c357fb08cc10), attached gdb, and got the attached backtrace.
(Reporter)

Comment 1

3 years ago
Created attachment 8541261 [details]
backtrace

I caught a hang in gdb again but this time running a binary I downloaded.
(Reporter)

Comment 2

3 years ago
Jeff helped me a bit.  The compositor thread is more interesting:

#0  0x0000003c9d00c590 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
(gdb) bt
#0  0x0000003c9d00c590 in pthread_cond_wait@@GLIBC_2.3.2 ()
    at /lib64/libpthread.so.0
#1  0x00000036dbe0a3d9 in _xcb_conn_wait () at /lib64/libxcb.so.1
#2  0x00000036dbe0b639 in xcb_wait_for_special_event () at /lib64/libxcb.so.1
#3  0x00007f6746bf4034 in dri3_find_back () at /lib64/libGL.so.1
#4  0x00007f6746bf471d in dri3_get_buffer.isra () at /lib64/libGL.so.1
#5  0x00007f6746bf538a in dri3_get_buffers () at /lib64/libGL.so.1
#6  0x00007f672a1b20b7 in intel_update_renderbuffers ()
    at /usr/lib64/dri/i965_dri.so
#7  0x00007f672a1b23e5 in intel_prepare_render () at /usr/lib64/dri/i965_dri.so
#8  0x00007f672a1a6dcd in brw_clear () at /usr/lib64/dri/i965_dri.so
#9  0x00007f674819b612 in mozilla::gl::GLContext::fClear(unsigned int) ()
    at /home/overholt/.local/firefox/libxul.so
#10 0x00007f67481a5d61 in mozilla::layers::CompositorOGL::BeginFrame(nsIntRegion const&, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const*, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits>*, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits>*) ()
    at /home/overholt/.local/firefox/libxul.so
#11 0x00007f6748184022 in mozilla::layers::LayerManagerComposite::Render() ()
    at /home/overholt/.local/firefox/libxul.so

I'm quite confident this is due to some prefs I have set ....
Summary: Hang in mozilla::layers::PLayerTransactionChild::SendUpdate (?) on Fedora 21 → Compositor hang with Intel driver (on Fedora 21)
The special_event queue is used for present events. This happens using the XCB Present Extension.
Do you have hardware acceleration enabled? This looks like bug 1069523.
(Reporter)

Comment 5

3 years ago
I can't say for sure since it hasn't happened again *yet* but it looks like it was the prefs I had flipped for forced OMTC and/or forced hardware acceleration.

It does indeed look like bug 1069523 so I'll dupe it there. Thanks!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1069523
You need to log in before you can comment on or make changes to this bug.